Last Comment Bug 734946 - Disable incremental GC for Firefox 13
: Disable incremental GC for Firefox 13
Status: VERIFIED FIXED
[qa!]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 11:08 PDT by Bill McCloskey (:billm)
Modified: 2012-05-17 23:48 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1022 bytes, patch)
2012-03-12 11:08 PDT, Bill McCloskey (:billm)
dmandelin: review+
Details | Diff | Review

Description Bill McCloskey (:billm) 2012-03-12 11:08:16 PDT
Created attachment 605013 [details] [diff] [review]
patch

I haven't made much progress in fixing the leaks related to bug 728686, and I think it's a bad idea to ship in the state we're in (where incremental GC gets randomly disabled). I think it would be better to disable incremental GC by default and then land the patch for bug 728686. That way, people who choose to opt in to incremental GC will have it on all the time.
Comment 1 David Mandelin [:dmandelin] 2012-03-12 12:47:59 PDT
Do you think it would be useful to provide a tiny Jetpack add-on to enable IGC?
Comment 2 Bill McCloskey (:billm) 2012-03-12 18:38:55 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8cae4bde9534

(In reply to David Mandelin from comment #1)
> Do you think it would be useful to provide a tiny Jetpack add-on to enable
> IGC?

I don't know. about:config doesn't seem like much of a barrier to entry to me.
Comment 3 Bill McCloskey (:billm) 2012-03-12 22:45:38 PDT
Blargh. Tryserver shows *this* patch to be leaking. Has the world gone mad?

https://hg.mozilla.org/integration/mozilla-inbound/rev/6799a5e6912f
Comment 4 Patrick Walton (:pcwalton) 2012-03-13 00:42:31 PDT
If we're in a situation in which our tests are telling us that incremental GC is required in order to stop Firefox from leaking, that's bad. I would think that this has to be fixed on Aurora before Firefox 13 can be released.

Since it looks like IGC is going to get uplifted (as I assume uplifts can't happen unless our trees are green), could we just land IGC leak fixes on Aurora?
Comment 6 Marco Bonardo [::mak] 2012-03-13 05:53:40 PDT
https://hg.mozilla.org/mozilla-central/rev/8cae4bde9534
Comment 7 Marco Bonardo [::mak] 2012-03-13 05:58:55 PDT
Actually, looks like Bill backed this out.
Comment 8 Bill McCloskey (:billm) 2012-03-13 08:12:42 PDT
https://hg.mozilla.org/mozilla-central/rev/a625b9ed671f

Relanded. Looks like the leaks were "fixed" in bug 734554. This sort of thing makes me hate Firefox.
Comment 9 Daniel Cater 2012-03-13 12:47:07 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120313 Firefox/13.0a1

about:config shows javascript.options.mem.gc_incremental;false yet about:support shows:

JavaScript
Incremental GC: 1

Is that a bug?
Comment 10 Bill McCloskey (:billm) 2012-03-13 14:00:18 PDT
(In reply to Daniel Cater from comment #9)
> Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120313 Firefox/13.0a1
> 
> about:config shows javascript.options.mem.gc_incremental;false yet
> about:support shows:
> 
> JavaScript
> Incremental GC: 1
> 
> Is that a bug?

It's not a bug, although it's admittedly confusing. The about:support line is only showing whether incremental GC is permanently disabled due to binary add-ons. Incremental GC may also be disabled for other reasons (like the preference being off).
Comment 11 Ioana (away) 2012-03-20 09:05:22 PDT
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120318 Firefox/13.0a2
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120319 Firefox/13.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20120318 Firefox/13.0a2

Note You need to log in before you can comment on or make changes to this bug.