Last Comment Bug 735127 - Fix "beause" spelling
: Fix "beause" spelling
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: P4 trivial (vote)
: mozilla14
Assigned To: Pallani Kumaran
:
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 738160 738161
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 18:03 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-03-25 09:14 PDT (History)
1 user (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.02 KB, patch)
2012-03-14 09:25 PDT, Pallani Kumaran
bugzillamozillaorg_serge_20140323: feedback-
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2012-03-12 18:03:37 PDT
Use "because".

"Found 3 matching lines in 3 files"
But leave /ipc alone.
Comment 1 Pallani Kumaran 2012-03-13 13:33:41 PDT
Hello. I would like to work on this bug.
Comment 2 Serge Gautherie (:sgautherie) 2012-03-13 13:51:51 PDT
Just do.
Comment 3 Pallani Kumaran 2012-03-14 09:25:57 PDT
Created attachment 605798 [details] [diff] [review]
Patch
Comment 4 Serge Gautherie (:sgautherie) 2012-03-14 18:58:27 PDT
Comment on attachment 605798 [details] [diff] [review]
Patch

Review of attachment 605798 [details] [diff] [review]:
-----------------------------------------------------------------

I marked this bug as meta because all 3 files are in different components which have (very) different review rules (iirc).
Please, split them into 2(-3) blocking bugs.

::: ipc/chromium/src/third_party/libevent/event.c
@@ +881,5 @@
>  	evutil_timersub(&base->event_tv, tv, &off);
>  
>  	/*
>  	 * We can modify the key element of the node without destroying
> +	 * the key, because we apply it to all in the right order.

That's correct, but I think chromium is external/upstream and should not be touched. (To be confirmed.)

::: security/nss/lib/pk11wrap/pk11auth.c
@@ +164,5 @@
>  	len = PORT_Strlen(pw);
>      }
>  
>      /*
> +     * If the token does't need a login, don't try to relogin because the

While here, fix "does't" too.
Comment 5 Pallani Kumaran 2012-03-14 19:37:44 PDT
So there should be two different patch files? I do not know what "split them into 2(-3) blocking bugs" means.
Comment 6 Serge Gautherie (:sgautherie) 2012-03-14 20:32:06 PDT
(In reply to Pallani Kumaran from comment #5)

> So there should be two different patch files?

Yes.

> I do not know what "split them into 2(-3) blocking bugs" means.

It means: file 2 bugs, making them block this one, attach related patch to each.
Comment 7 Pallani Kumaran 2012-03-14 21:48:04 PDT
Ok. I should do that for bug 735124 also?
Comment 8 Serge Gautherie (:sgautherie) 2012-03-15 20:01:48 PDT
(In reply to Pallani Kumaran from comment #7)
> Ok. I should do that for bug 735124 also?

Answered there ;-)
Comment 9 Serge Gautherie (:sgautherie) 2012-03-25 09:13:58 PDT
V.Fixed, per blocking bugs.

Note You need to log in before you can comment on or make changes to this bug.