Last Comment Bug 735187 - Re-enable inline autocomplete once its blockers are fixed
: Re-enable inline autocomplete once its blockers are fixed
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Marco Bonardo [::mak]
:
: Marco Bonardo [::mak]
Mentors:
Depends on: 740076
Blocks: 566489
  Show dependency treegraph
 
Reported: 2012-03-13 03:26 PDT by Marco Bonardo [::mak]
Modified: 2016-05-13 00:40 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Marco Bonardo [::mak] 2012-03-13 03:26:23 PDT
Filing this just to track the re-enable.
Comment 2 Marco Bonardo [::mak] 2012-03-13 07:01:12 PDT
https://hg.mozilla.org/mozilla-central/rev/1ffea9163a9d
Comment 3 IU 2012-03-14 17:24:53 PDT
What is the about:config pref to disable this thing?

browser.urlbar.autocomplete.enabled set to false does nothing.  Is this a bug?  I need this disabled, because I use an extension called URL Alias, and this autocomplete is seriously screwing up my workflow.

Thanks
Comment 4 IU 2012-03-14 17:39:43 PDT
I see that the pref now used is browser.urlbar.autoFill; however, "browser.urlbar.autocomplete.enabled" still exists as a valid default pref (which apparently does nothing).  I guess someone should delete that.
Comment 5 Marco Bonardo [::mak] 2012-03-14 17:51:07 PDT
(In reply to IU from comment #4)
> I see that the pref now used is browser.urlbar.autoFill; however,
> "browser.urlbar.autocomplete.enabled" still exists as a valid default pref
> (which apparently does nothing).  I guess someone should delete that.

browser.urlbar.autocomplete.enabled controls the autocomplete popup results.
browser.urlbar.autoFill controls the urlbar autofill results.
Comment 6 Ed Lee :Mardak 2012-03-16 12:20:43 PDT
Just to confirm, autoFill is true on Aurora 13 right now. You just can't update to it on the aurora branch yet per bug 735421.
Comment 7 Marco Bonardo [::mak] 2012-04-10 07:20:01 PDT
Gavin, what does the dependency mean? should we consider bug 740076 a blocker?
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-10 11:54:26 PDT
No, I just wanted to indicate that that bug was a regression from re-enabling inline autocomplete (and thus should probably be fixed for 13, where this landed).
Comment 9 Josh Triplett 2016-05-12 10:11:03 PDT
If this is the change that makes the awesomebar show the top-level site above the most relevant page: how can I turn this *off*, and should it be off by default?  When I type 'y', the top entry used to be https://www.youtube.com/feed/subscriptions , which I have bookmarked and visit regularly (as I find it far more useful than the front page).  However, now I see "Visit youtube.com/" as the top entry, and have to hit down once to get to the relevant bookmark for the subscriptions page.

I don't even have youtube.com in my history; I've repeatedly deleted it from there.  Despite that, I occasionally find myself visiting the front page by accident because I didn't hit "down" before "enter".

I understand that in some cases it may make sense to prioritize the top-level site instead of one of many pages visited from that site.  But when there's a page that's far more relevant (and even bookmarked), and the front page has little to no frecency, there should be some threshold where the top-level site stays buried where it belongs.
Comment 10 Marco Bonardo [::mak] 2016-05-13 00:40:44 PDT
(In reply to Josh Triplett from comment #9)
> If this is the change that makes the awesomebar show the top-level site
> above the most relevant page: how can I turn this *off*, and should it be
> off by default?  When I type 'y', the top entry used to be
> https://www.youtube.com/feed/subscriptions , which I have bookmarked and
> visit regularly (as I find it far more useful than the front page). 
> However, now I see "Visit youtube.com/" as the top entry, and have to hit
> down once to get to the relevant bookmark for the subscriptions page.

You can disable browser.urlbar.autoFill, but you'll still not get the behavior you are expecting, for that you may need a userChrome css hack to hide the first autocomplete row. I know it has been posted multiple times on the firefox reddit group.

> I don't even have youtube.com in my history; I've repeatedly deleted it from
> there.  Despite that, I occasionally find myself visiting the front page by
> accident because I didn't hit "down" before "enter".

Regardless, even hiding the first row, you'll have to down before enter. It has been like that from a long time. Maybe you were using an add'on like EnterSelects?

> I understand that in some cases it may make sense to prioritize the
> top-level site instead of one of many pages visited from that site.  But
> when there's a page that's far more relevant (and even bookmarked), and the
> front page has little to no frecency, there should be some threshold where
> the top-level site stays buried where it belongs.

Thank you for your feedback, we are indeed already evaluating alternatives in bug 1239708.

Note You need to log in before you can comment on or make changes to this bug.