Last Comment Bug 735223 - Drop support for ancient NDKs
: Drop support for ancient NDKs
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks: 756575
  Show dependency treegraph
 
Reported: 2012-03-13 07:14 PDT by Mike Hommey [:glandium]
Modified: 2012-06-02 12:05 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Drop support for ancient NDKs (8.09 KB, patch)
2012-05-15 01:54 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Drop support for ancient NDKs (11.15 KB, patch)
2012-05-18 23:13 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Drop support for ancient NDKs (nspr part) (3.46 KB, patch)
2012-05-18 23:22 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-03-13 07:14:57 PDT
We're not even sure we still build successfully with these, so I think we can get rid of the configure checks that make us support older NDKs.
Comment 1 Mike Hommey [:glandium] 2012-05-15 01:54:46 PDT
Created attachment 623976 [details] [diff] [review]
Drop support for ancient NDKs

try: -b do -p android,android-xul,b2g -u none -t none
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-05-15 10:49:30 PDT
Comment on attachment 623976 [details] [diff] [review]
Drop support for ancient NDKs

Review of attachment 623976 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +247,2 @@
>      MOZ_ANDROID_LIBSTDCXX=1,
>      MOZ_ANDROID_LIBSTDCXX= )

Does this option actually work? If not, we should probably just drop it.
Comment 3 Mike Hommey [:glandium] 2012-05-18 23:13:32 PDT
Created attachment 625355 [details] [diff] [review]
Drop support for ancient NDKs

(In reply to Ted Mielczarek [:ted] from comment #2)
> ::: configure.in
> @@ +247,2 @@
> >      MOZ_ANDROID_LIBSTDCXX=1,
> >      MOZ_ANDROID_LIBSTDCXX= )
> 
> Does this option actually work? If not, we should probably just drop it.

It appears it doesn't, and it went undectected for a while, seeing how it fails
(first failure is a failure to link because system android's libstdc++.so is picked before gnu libstdc++.a ; second failure is because std::wstring, used in ipc/chromium headers, is not defined unless _GLIBCXX_USE_WCHAR_T is defined, which requires -fshort-wchar, which we haven't been using for a while)

Also, considering the fact that libstdc++.a is, like stlport, only built for a limited set of things, and that its source is not in the ndk, like stlport, using it is likely to break depending on the arch build flags we use. All in all, stlport is the safest option.
Comment 4 Mike Hommey [:glandium] 2012-05-18 23:22:38 PDT
Created attachment 625356 [details] [diff] [review]
Drop support for ancient NDKs (nspr part)

Same, but for nspr. This also fixes android-toolchain auto-detection for x86
<none>
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-05-19 09:38:48 PDT
Comment on attachment 625356 [details] [diff] [review]
Drop support for ancient NDKs (nspr part)

Checking in configure;
/cvsroot/mozilla/nsprpub/configure,v  <--  configure
new revision: 1.328; previous revision: 1.327
done
Checking in configure.in;
/cvsroot/mozilla/nsprpub/configure.in,v  <--  configure.in
new revision: 1.331; previous revision: 1.330
done
Comment 8 :Ehsan Akhgari 2012-06-02 12:05:36 PDT
NSPR upgrade: https://hg.mozilla.org/mozilla-central/rev/22a080ac092e

Note You need to log in before you can comment on or make changes to this bug.