Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 735286 - Missing chat inverse icon
: Missing chat inverse icon
: polish
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86 Windows 7
: -- minor (vote)
: Thunderbird 14.0
Assigned To: Andreas Nilsson (:andreasn)
Depends on:
Blocks: 714733
  Show dependency treegraph
Reported: 2012-03-13 09:47 PDT by [:Aureliano Buendía]
Modified: 2012-04-17 09:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---

bug-in-action (30.77 KB, image/png)
2012-03-13 09:47 PDT, [:Aureliano Buendía]
no flags Details
adding missing graphics (8.28 KB, patch)
2012-03-26 11:19 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Splinter Review
patch (v2) (23.84 KB, patch)
2012-03-26 12:25 PDT, Andreas Nilsson (:andreasn)
mconley: review+
Details | Diff | Splinter Review
Patch (v3) (24.25 KB, patch)
2012-04-12 11:23 PDT, Mike Conley (:mconley) - (high latency on reviews and needinfos)
mconley: review+
bwinton: ui‑review+
Details | Diff | Splinter Review

Description [:Aureliano Buendía] 2012-03-13 09:47:29 PDT
Created attachment 605430 [details]

When move chat button near search icon (or if installed also calendar and task icon), TB display an empty square
Comment 1 Andreas Nilsson (:andreasn) 2012-03-26 11:19:45 PDT
Created attachment 609391 [details] [diff] [review]
adding missing graphics

I think this should do it.
Comment 2 Andreas Nilsson (:andreasn) 2012-03-26 12:25:33 PDT
Created attachment 609426 [details] [diff] [review]
patch (v2)

Apparently it was missing a little bit of css, and that made it look fuzzy.
Also made sure the regular toolbar graphics got cropped back to 18px high (was 19px for some reason).
Comment 3 Mike Conley (:mconley) - (high latency on reviews and needinfos) 2012-03-26 12:43:44 PDT
Comment on attachment 609426 [details] [diff] [review]
patch (v2)

Review of attachment 609426 [details] [diff] [review]:

Looks good to me.

::: mail/themes/qute/mail/primaryToolbar-aero.css
@@ +261,4 @@
>      #button-goforward, #button-compact, #button-archive, #hdrArchiveButton,
>      #hdrReplyButton, #hdrReplyToSenderButton, #hdrReplyAllButton,
>      #hdrReplyOnlyButton, #hdrReplyListButton, #hdrForwardButton,
> +    #hdrTrashButton, #hdrJunkButton, #qfb-show-filter-bar, #button-chat

Hrm.  There's gotta be a better way of doing this rather than maintaining this big list of IDs.


Maybe another class applied to all of our toolbar buttons?  I don't know.

Meh - just recording my objection to this long list here.  I'm not going to make you fix all of that stuff since it's unrelated to the patch.  :)
Comment 4 Mike Conley (:mconley) - (high latency on reviews and needinfos) 2012-04-12 11:23:19 PDT
Created attachment 614466 [details] [diff] [review]
Patch (v3)

Un-bitrotting this patch, and transferring my r+.
Comment 5 Blake Winton (:bwinton) (:☕️) 2012-04-12 11:31:06 PDT
Comment on attachment 614466 [details] [diff] [review]
Patch (v3)

ui-r=me, based on the screenshot in IRC.

Comment 6 Mike Conley (:mconley) - (high latency on reviews and needinfos) 2012-04-17 09:09:33 PDT
Committed to comm-central as

Note You need to log in before you can comment on or make changes to this bug.