Last Comment Bug 735355 - Update mozmill tests to use MPL2 license block
: Update mozmill tests to use MPL2 license block
Status: RESOLVED FIXED
[mozmill-refactor][qa-]
:
Product: Mozilla QA
Classification: Other
Component: Mozmill Tests (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Alex Lakatos[:AlexLakatos]
:
Mentors:
http://hg.mozilla.org/qa/mozmill-tests/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 11:35 PDT by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2012-08-14 14:57 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed
fixed
fixed
fixed


Attachments
patch v1.0 (433.95 KB, patch)
2012-03-23 06:32 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review-
Details | Diff | Splinter Review
patch v2.0 (454.45 KB, patch)
2012-03-26 08:54 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review-
Details | Diff | Splinter Review
fix v2.1 (default) [landed] (454.50 KB, patch)
2012-03-27 07:10 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review+
Details | Diff | Splinter Review
fix v2.1 (aurora) [landed] (454.54 KB, patch)
2012-03-29 10:42 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review+
Details | Diff | Splinter Review
fix v2.1 (beta) [landed] (454.25 KB, patch)
2012-03-29 10:44 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review+
Details | Diff | Splinter Review
fix v2.1 (release) [landed] (451.78 KB, patch)
2012-03-29 10:44 PDT, Alex Lakatos[:AlexLakatos]
anthony.s.hughes: review+
Details | Diff | Splinter Review
fix v2.1 (esr) (423.71 KB, patch)
2012-07-25 12:00 PDT, Alex Lakatos[:AlexLakatos]
dave.hunt: review-
Details | Diff | Splinter Review
fix v2.2 (esr) (428.43 KB, patch)
2012-07-25 15:38 PDT, Dave Hunt (:davehunt)
hskupin: review+
Details | Diff | Splinter Review

Description Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-13 11:35:33 PDT
The following is a tracking bug for updating all Mozmill tests to use the MPL2 license block, as follows.

Replace this...
>/* ***** BEGIN LICENSE BLOCK *****
> * Version: MPL 1.1/GPL 2.0/LGPL 2.1
> *
> * The contents of this file are subject to the Mozilla Public License Version
> * 1.1 (the "License"); you may not use this file except in compliance with
> * the License. You may obtain a copy of the License at
> * http://www.mozilla.org/MPL/
> *
> * Software distributed under the License is distributed on an "AS IS" basis,
> * WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
> * for the specific language governing rights and limitations under the
> * License.
> *
> * The Original Code is MozMill Test code.
> *
> * The Initial Developer of the Original Code is the Mozilla Foundation.
> * Portions created by the Initial Developer are Copyright (C) 2011
> * the Initial Developer. All Rights Reserved.
> *
> * Contributor(s):
> *   name <email> (original author)
> *
> * Alternatively, the contents of this file may be used under the terms of
> * either the GNU General Public License Version 2 or later (the "GPL"), or
> * the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
> * in which case the provisions of the GPL or the LGPL are applicable instead
> * of those above. If you wish to allow use of your version of this file only
> * under the terms of either the GPL or the LGPL, and not to allow others to
> * use your version of this file under the terms of the MPL, indicate your
> * decision by deleting the provisions above and replace them with the notice
> * and other provisions required by the GPL or the LGPL. If you do not delete
> * the provisions above, a recipient may use your version of this file under
> * the terms of any one of the MPL, the GPL or the LGPL.
> *
> * ***** END LICENSE BLOCK ***** */

With this...
> /* This Source Code Form is subject to the terms of the Mozilla Public
> * License, v. 2.0. If a copy of the MPL was not distributed with this file,
> * You can obtain one at http://mozilla.org/MPL/2.0/.
> */

This applies to everything in the tests, lib, and templates folders.
This applies to default, mozilla-aurora, mozilla-beta, mozilla-release, and mozilla-esr10 branches.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-13 11:36:39 PDT
Pausing here for feedback before we proceed with implementation.

Do we want to split this work into multiple bugs?
Do we have any concerns with the license block?
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-13 11:44:29 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #1)

> Do we want to split this work into multiple bugs?
My personal opinion is that we do everything in this bug but handle it in multiple patches (one for tests, one for lib, one for templates).

> Do we have any concerns with the license block?
My personal opinion is that the new license block is a drastic improvement over the old one.
Comment 3 Henrik Skupin (:whimboo) 2012-03-13 22:42:41 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> > Do we want to split this work into multiple bugs?
> My personal opinion is that we do everything in this bug but handle it in
> multiple patches (one for tests, one for lib, one for templates).

Why? I don't understand. Gerv has a script which is doing that automatically. So I'm not sure why people have to create patches for it manually.

> > Do we have any concerns with the license block?
> My personal opinion is that the new license block is a drastic improvement
> over the old one.

Something I would like to see addressed before is an AUTHORS file. It should contain all the contributors to the mozmill-tests repository.
Comment 4 Gervase Markham [:gerv] 2012-03-14 03:04:51 PDT
I have a script for doing this, and any file with an existing license block will be converted in bug 716478, which covers all of mozilla-central and comm-central.

If you do make a change, can you please use the boilerplate formatted exactly as here:
http://www.mozilla.org/MPL/headers/
and not the one in comment 0?

Gerv
Comment 5 Alex Lakatos[:AlexLakatos] 2012-03-23 06:32:54 PDT
Created attachment 608679 [details] [diff] [review]
patch v1.0

Ran the script on all folders, except the addons tests.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-23 11:54:45 PDT
Comment on attachment 608679 [details] [diff] [review]
patch v1.0

Patch is good except that the script missed some of the files. Please update your patch to include the following files (you'll need to do this manually):

 * lib/software-update.js
 * tests/functional/testAwesomeBar/testAccessLocationBar.js
 * tests/functional/testAwesomeBar/testLocationBarSearches.js
 * tests/functional/testAwesomeBar/testPasteLocationBar.js
 * tests/functional/testPopups/testPopupsBlocked.js
 * tests/functional/testSecurity/testEncryptedPageWarning.js
 * tests/functional/testSecurity/testSafeBrowsingNotificationBar.js
 * tests/functional/testSecurity/testSafeBrowsingWarningPages.js
 * tests/functional/testSecurity/testSubmitUnencryptedInfoWarning.js
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-23 11:56:36 PDT
NOTE: We should follow this up with a patch to add a license block to the test data as per http://www.mozilla.org/MPL/headers/ but I think we take care of that on a separate bug.
Comment 8 Alex Lakatos[:AlexLakatos] 2012-03-26 08:54:41 PDT
Created attachment 609339 [details] [diff] [review]
patch v2.0

Manually edited the missing files.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-26 21:33:43 PDT
Comment on attachment 609339 [details] [diff] [review]
patch v2.0

Looks good, thanks Alex.
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-26 21:35:58 PDT
Comment on attachment 609339 [details] [diff] [review]
patch v2.0

Sorry, changing to r-. Patch fails to apply for libs/places.js. Please update the patch.
Comment 11 Alex Lakatos[:AlexLakatos] 2012-03-27 07:10:54 PDT
Created attachment 609703 [details] [diff] [review]
fix v2.1 (default) [landed]

This one applies cleanly
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-28 21:59:32 PDT
Comment on attachment 609703 [details] [diff] [review]
fix v2.1 (default) [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/ff2332f6f494 (default)
Comment 13 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-28 22:00:15 PDT
Alex, please verify this does not cause any regressions with tomorrow's Nightly testrun. If not we can port this to the other branches.

Thanks
Comment 14 Alex Lakatos[:AlexLakatos] 2012-03-29 10:42:43 PDT
Created attachment 610593 [details] [diff] [review]
fix v2.1 (aurora) [landed]

patch for the mozilla-aurora branch
Comment 15 Alex Lakatos[:AlexLakatos] 2012-03-29 10:44:10 PDT
Created attachment 610596 [details] [diff] [review]
fix v2.1 (beta) [landed]

patch for the mozilla-beta branch
Comment 16 Alex Lakatos[:AlexLakatos] 2012-03-29 10:44:41 PDT
Created attachment 610597 [details] [diff] [review]
fix v2.1 (release) [landed]

patch for the mozilla-release branch
Comment 17 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 11:07:36 PDT
Comment on attachment 610593 [details] [diff] [review]
fix v2.1 (aurora) [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/28b21a2b736b (mozilla-aurora)
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 11:10:14 PDT
Comment on attachment 610596 [details] [diff] [review]
fix v2.1 (beta) [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/c5e97b682a9e (mozilla-beta)
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 11:13:11 PDT
Comment on attachment 610597 [details] [diff] [review]
fix v2.1 (release) [landed]

This patch seems to miss:
 * /tests/endurance/testAddons_OpenAndCloseExtensionList/test1.js
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 11:13:37 PDT
Additionally, please prepare patches for 1.9.2 and esr10.
Comment 21 Alex Lakatos[:AlexLakatos] 2012-03-29 14:09:36 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #19)
> Comment on attachment 610597 [details] [diff] [review]
> fixPatch v2.1[release]
> 
> This patch seems to miss:
>  * /tests/endurance/testAddons_OpenAndCloseExtensionList/test1.js
That's because the release branch does not have that test in it:
http://hg.mozilla.org/qa/mozmill-tests/file/mozilla-release/tests/endurance
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 14:50:32 PDT
(In reply to Alex Lakatos[:AlexLakatos] from comment #21)
> That's because the release branch does not have that test in it:
> http://hg.mozilla.org/qa/mozmill-tests/file/mozilla-release/tests/endurance

Ah yes, you are right. Thanks.
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 14:52:19 PDT
Comment on attachment 610597 [details] [diff] [review]
fix v2.1 (release) [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/c5e97b682a9e (mozilla-release)
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 14:55:03 PDT
Please provide a patch for esr10 and 1.9.2 -- thanks.
Comment 25 Henrik Skupin (:whimboo) 2012-03-29 21:51:12 PDT
(In reply to Alex Lakatos[:AlexLakatos] from comment #21)
> > This patch seems to miss:
> >  * /tests/endurance/testAddons_OpenAndCloseExtensionList/test1.js
> That's because the release branch does not have that test in it:
> http://hg.mozilla.org/qa/mozmill-tests/file/mozilla-release/tests/endurance

Huh, why? What's the reason for? Did we miss it?
Comment 26 Maniac Vlad Florin (:vladmaniac) 2012-03-30 00:26:01 PDT
(In reply to Henrik Skupin (:whimboo) from comment #25)
> (In reply to Alex Lakatos[:AlexLakatos] from comment #21)
> > > This patch seems to miss:
> > >  * /tests/endurance/testAddons_OpenAndCloseExtensionList/test1.js
> > That's because the release branch does not have that test in it:
> > http://hg.mozilla.org/qa/mozmill-tests/file/mozilla-release/tests/endurance
> 
> Huh, why? What's the reason for? Did we miss it?

It seems we missed it. That test was suppose to land on all branches
Comment 27 Henrik Skupin (:whimboo) 2012-03-30 00:28:43 PDT
So please make a comment in the appropriate bug. We should transplant it over.
Comment 28 Gervase Markham [:gerv] 2012-03-30 01:29:14 PDT
You really don't have to do all the historic branches; the main Mozilla relicensing effort is only doing the trunk, and letting it "filter down" over time.

Gerv
Comment 29 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-04-02 11:22:42 PDT
(In reply to Henrik Skupin (:whimboo) from comment #27)
> So please make a comment in the appropriate bug. We should transplant it
> over.

I found out what happened. Bug 705118 covers the work for that test. It was landed on default on Jan 9th but Vlad failed to verify it was passing so it never got ported. Subsequently it was merged forward to aurora on Jan 31 and beta on Mar 16.

We can deal with this on bug 705118.
Comment 30 Dave Hunt (:davehunt) 2012-07-24 08:05:04 PDT
Let's backport this to ESR as it's causing us to create patches where the only difference is the license. Alex or Vlad, can you take this?
Comment 31 Alex Lakatos[:AlexLakatos] 2012-07-24 08:08:01 PDT
I'll take it, it was mine in the first place.
Comment 32 Henrik Skupin (:whimboo) 2012-07-24 08:08:47 PDT
This is actually fixed but only needs a backport to esr10. Thanks Alex for taking it!
Comment 33 Alex Lakatos[:AlexLakatos] 2012-07-25 12:00:06 PDT
Created attachment 645844 [details] [diff] [review]
fix v2.1 (esr)

fix for the esr branch
If you want to check the file names in the diff view of bugzilla, here is a livemark that collapses them for you:
>javascript:(function(){for(i=0;i<document.getElementsByTagName("a").length;%20i++){if(document.getElementsByTagName("a")[i].onclick!=null){evt=document.createEvent("MouseEvents");evt.initMouseEvent("click",%20true,%20true,%20window,%200,%200,%200,%200,%200,%20false,%20false,%20false,%20false,%200,%20null);document.getElementsByTagName("a")[i].dispatchEvent(evt);}}})()
Comment 34 Alex Lakatos[:AlexLakatos] 2012-07-25 12:02:45 PDT
(In reply to Alex Lakatos[:AlexLakatos] from comment #33)
> If you want to check the file names in the diff view of bugzilla, here is a
> livemark that collapses them for you:
Ignore the fact there is a "Collapse All" link. Seems to be broken in my Nightly with my dirty profile, but just tried it on a clean one and it works.
Comment 35 Dave Hunt (:davehunt) 2012-07-25 15:35:02 PDT
Comment on attachment 645844 [details] [diff] [review]
fix v2.1 (esr)

A couple of files in lib were missed. Updated patch incoming.
Comment 36 Dave Hunt (:davehunt) 2012-07-25 15:38:02 PDT
Created attachment 645913 [details] [diff] [review]
fix v2.2 (esr)

$ grep -R "MPL 1.1" . --exclude=*.patch | wc -l
       0
Comment 37 Henrik Skupin (:whimboo) 2012-07-25 15:41:19 PDT
Comment on attachment 645913 [details] [diff] [review]
fix v2.2 (esr)

I trust your grep code, Dave! Good you caught that. Lets get it landed.
Comment 38 Henrik Skupin (:whimboo) 2012-07-26 04:23:59 PDT
Patch for esr10 landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/b69834b26946

Note You need to log in before you can comment on or make changes to this bug.