about:newtab has on-hover UI that doesn't work well with touch-screens

RESOLVED FIXED in Firefox 13

Status

()

Firefox
General
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: Unfocused, Assigned: Unfocused)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 14
x86
Windows 8
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(firefox13 verified)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

Running a Windows 8 tablet - touch-screen, no mouse. The new tab page has on-hover UI (pin/unpin, forget) that doesn't work well with a touch-screen.

Current workaround is to start moving a thumbnail, drop it in it's original place, then hit one of the buttons.
Might be able to include a CSS media type for handheld which makes the buttons always visible?

@media handheld {
  .newtab-control {
    opacity: 1;
  }
}

in /browser/base/content/newtab/newTab.css
That sounds like a good idea to me. I unfortunately don't have a handheld that runs default Firefox. Anyone willing to test this? Should I kick off a try build?
A tablet isn't a handheld. You want -moz-touch-enabled.
Created attachment 606161 [details] [diff] [review]
Patch v1

This works.
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attachment #606161 - Flags: review?(ttaubert)
Comment on attachment 606161 [details] [diff] [review]
Patch v1

Review of attachment 606161 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thank you!
Attachment #606161 - Flags: review?(ttaubert) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/5673f647d33a
Flags: in-testsuite-
Flags: in-litmus-
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 14
Comment on attachment 606161 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Regression caused by (bug #): new newtab layout
User impact if declined: thumbnail controls unreachable on touch devices running desktop firefox
Risk to taking this patch (and alternatives if risky): small css-only fix, virtually no risk
String changes made by this patch: none
Attachment #606161 - Flags: approval-mozilla-aurora?
Comment on attachment 606161 [details] [diff] [review]
Patch v1

[Triage Comment]
Looks good, low risk and positive user experience impact.
Attachment #606161 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/5673f647d33a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/releases/mozilla-aurora/rev/15c41c2337fb
status-firefox13: --- → fixed
Whiteboard: [qa+]
Verified on Fx13b6 20120528154913 on a touch screen machine with Windows 8 Consumer Preview. Previous builds do not show the pin/remove icons, but they always show on Fx13b6.
status-firefox13: fixed → verified
Thanks Juan.
Blocks: 1055531
You need to log in before you can comment on or make changes to this bug.