Add hover effect in URL and search bars when using personas

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Theme
--
enhancement
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Christian Ascheberg, Assigned: Christian Ascheberg)

Tracking

Trunk
Firefox 29
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first verify], [testday-20140328])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Created attachment 605694 [details] [diff] [review]
patch v1

STR:
1. apply personas
2. move mouse over urlbar / searchbar

expected:
urlbar has hover effect, background color is less transparent

actual:
no hover effect anymore -> urlbar feels broken / unresponsive


The reason for the change is the patch in bug 692537, line 256.
Instead of "#urlbar:hover", the hover effect is now only applied when "#navigator-toolbox[tabsontop=false] #urlbar:not(:-moz-lwtheme):hover" is true.
I guess that was not intended for personas?
Attachment #605694 - Flags: review?(shorlander)
Comment on attachment 605694 [details] [diff] [review]
patch v1

This change was intended in that the previous hover effect wasn't supposed to apply to personas in the first place. It was aero glass specific.

Now, we could decide that we want the hover effect, but it's unclear why this should be personas-specific. Also, we wouldn't use the magic 0.898 opacity here which was only chosen to match Windows explorer.
Attachment #605694 - Flags: review?(shorlander) → review-
(Assignee)

Comment 2

6 years ago
(In reply to Dão Gottwald [:dao] from comment #1)
> Comment on attachment 605694 [details] [diff] [review]
> patch v1
> 
> This change was intended in that the previous hover effect wasn't supposed
> to apply to personas in the first place. It was aero glass specific.
> 
> Now, we could decide that we want the hover effect, but it's unclear why
> this should be personas-specific.

I think the urlbar looks better with the patch for bug 692537 as it is, and in my opinion there is no hover effect needed there.
I was just used to the hover effect when using personas, and I think it looked quite nice (no matter if it was actually meant to be aero glass specific).
Now, without the hover effect for personas the urlbar looks kind of unresponsive/deactivated to me, as with many personas the urlbar is darker than the default white background. The hover effect worked as a cue there.

That is why I think that a personas-specific hover effect should stay.
> That is why I think that a personas-specific hover effect should stay.

To clarify, it wasn't personas-specifc but aero-glass-specific and accidentally affected personas when using aero glass.


Stephen, should we do this?
Severity: normal → enhancement
Keywords: regression
Summary: hover effect in urlbar when using personas was removed → Add hover effect in URL and search bars when using personas
(Assignee)

Comment 4

6 years ago
Created attachment 613010 [details]
example

(In reply to Dão Gottwald [:dao] from comment #3)
> Stephen, should we do this?

This is an example of how it might look like.
3 steps: normal, hover, focused
(To be honest, I do not know if this image helps, it is not in the best quality.)
Attachment #613010 - Flags: feedback?(shorlander)
(Assignee)

Comment 5

5 years ago
Any new thoughts on this? I still think it's nice to have, as I said before:

(In reply to Christian Ascheberg from comment #2)
> Now, without the hover effect for personas the urlbar looks kind of
> unresponsive/deactivated to me, as with many personas the urlbar is darker
> than the default white background. The hover effect worked as a cue there.

The add-ons manager has a similar hover effect for the "search all add-ons" input field.
Comment on attachment 613010 [details]
example

Yes, I do like this. Let's a little of the persona through without any real drawbacks.
Attachment #613010 - Flags: feedback?(shorlander) → feedback+
(Assignee)

Comment 7

4 years ago
Created attachment 8344318 [details] [diff] [review]
patch v2

I updated the patch because of the feedback+.
Attachment #605694 - Attachment is obsolete: true
Attachment #8344318 - Flags: review?(shorlander)

Updated

4 years ago
Attachment #8344318 - Flags: review?(shorlander) → review+
https://hg.mozilla.org/integration/fx-team/rev/61bba9d9762c
https://hg.mozilla.org/mozilla-central/rev/61bba9d9762c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Updated

4 years ago
Whiteboard: [good first verify]
Verified fixed using Windows 7 64 bit and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Whiteboard: [good first verify] → [good first verify], [testday-20140328]
You need to log in before you can comment on or make changes to this bug.