Don't try to package MSVC dlls if WIN32_REDIST_DIR is not set, in SeaMonkey

VERIFIED FIXED in seamonkey2.11

Status

defect
P2
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: philip.chee, Assigned: sgautherie)

Tracking

({regression})

Trunk
seamonkey2.11
All
Windows 7
Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.9 verified, seamonkey2.10 verified)

Details

Attachments

(1 attachment, 2 obsolete attachments)

[chatzilla]
bin/distribution/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
[venkman]
bin/distribution/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
[inspector]
bin/distribution/extensions/inspector@mozilla.org.xpi
[debugqa]
bin/distribution/extensions/debugQA@mozilla.org.xpi
Error: found error(s) while packaging, see above for details.
c:\t1\hg\comm-central\mozilla\toolkit\mozapps\installer\packager.mk:758:0: command '/bin/sh /c/t1/hg/comm-central/mozilla/build/msys-perl-wrapper -Ic:/t1/hg/comm-central/mozilla/toolkit/mozapps/installer -e 'use Packager; Packager::Copy( "c:/t1/hg/objdir-sm/suite/installer/../../mozilla/dist", "c:/t1/hg/objdir-sm/suite/installer/../../mozilla/dist/seamonkey", "package-manifest", "dos", 1,1, 0, 1);'' failed, return code 9
c:\t1\hg\objdir-sm\suite\installer\windows\Makefile:83:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C .. installer-stage' failed, return code 2
c:\t1\hg\objdir-sm\suite\installer\Makefile:189:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C windows' failed, return code 2
c:\t1\hg\comm-central\suite\build.mk:76:0: command 'c:/DEV/mozilla-build/python/python.exe c:/t1/hg/comm-central/mozilla/build/pymake/pymake/../make.py -C suite/installer installer' failed, return code 2

Manually turning off MOZ_PKG_FATAL_WARNINGS and I see:

Warning: package error or possible missing or unnecessary file: bin/Microsoft.VC90.CRT.manifest (package-manifest, 52).
Warning: package error or possible missing or unnecessary file: bin/msvcm90.dll (package-manifest, 53).
Warning: package error or possible missing or unnecessary file: bin/msvcp90.dll (package-manifest, 54).
Warning: package error or possible missing or unnecessary file: bin/msvcr90.dll (package-manifest, 55).

According to Callek:

Callek>	RattyAway: ooo hrm, please open a new bug for that, mark it crit, and assign it to serge (ask him to fix it), but CC me
if he doesn't in the next day, I'll tackle it, should be easy the idea is to make it so that the win32_redist_dir need not be set for local devs, imo
OS: All → Windows 7
Hardware: All → x86_64
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #605887 - Flags: review?(bugspam.Callek)
Attachment #605887 - Flags: feedback?(philip.chee)
Flags: in-testsuite-
Hardware: x86_64 → All
Summary: Make it so that the win32_redist_dir need not be set for local developers. → Don't try to package MSVC dlls if WIN32_REDIST_DIR is not set, in SeaMonkey
Target Milestone: --- → seamonkey2.11
Depends on: 735810
Comment on attachment 605887 [details] [diff] [review]
(Av1) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set

Works for me locally.
Attachment #605887 - Flags: feedback?(philip.chee) → feedback+
Comment on attachment 605887 [details] [diff] [review]
(Av1) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set

Review of attachment 605887 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the caveat that I want this to match the Firefox solution if a review comes in with different nits there. But this can land now. (you can port nits from that bug to c-c for suite with rs+=me if you attach a copy of it here)

approval+ for this patch (not any extra m-c based nits) if you intend to land the "package warnings as errors" patch on aurora
Attachment #605887 - Flags: review?(bugspam.Callek)
Attachment #605887 - Flags: review+
Attachment #605887 - Flags: approval-comm-aurora+
Av1, enhanced and sync'ed with Firefox.
Attachment #605887 - Attachment is obsolete: true
Attachment #607415 - Flags: review?(bugspam.Callek)
Attachment #607415 - Flags: approval-comm-beta?
Attachment #607415 - Flags: approval-comm-aurora?
Attachment #607415 - Flags: review?(bugspam.Callek)
Attachment #607415 - Flags: approval-comm-beta?
Attachment #607415 - Flags: approval-comm-aurora?
Firefox patch backed out.
Av2, sync'ed with Firefox.
Attachment #610647 - Flags: review?(bugspam.Callek)
Attachment #610647 - Flags: approval-comm-beta?
Attachment #610647 - Flags: approval-comm-aurora?
Comment on attachment 610647 [details] [diff] [review]
(Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files
[Checked in: Comment 8 & 10 & 9]

rs+ assuming the meaningful change matches Firefox
Attachment #610647 - Flags: review?(bugspam.Callek) → review+
Attachment #607415 - Attachment is obsolete: true
Comment on attachment 610647 [details] [diff] [review]
(Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files
[Checked in: Comment 8 & 10 & 9]

http://hg.mozilla.org/comm-central/rev/ea634cabcdbd
Attachment #610647 - Attachment description: (Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files → (Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files [Checked in: Comment 8]
Severity: critical → normal
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Priority: P1 → P2
Resolution: --- → FIXED
Attachment #610647 - Flags: approval-comm-beta?
Attachment #610647 - Flags: approval-comm-beta+
Attachment #610647 - Flags: approval-comm-aurora?
Attachment #610647 - Flags: approval-comm-aurora+
Keywords: checkin-needed
Whiteboard: [c-n: ea634cabcdbd to c-a and c-b]
[on beta] Had to account for context changes in removed-files.in should be set though
[beta] http://hg.mozilla.org/releases/comm-beta/rev/df26107591e1
Whiteboard: [c-n: ea634cabcdbd to c-a and c-b] → [c-n: ea634cabcdbd to c-a]
V.Fixed, per still succeeding Windows builds.
seamonkey2.10 and seamonkey2.9: verified, per still succeeding Windows builds.
Status: RESOLVED → VERIFIED
Attachment #610647 - Attachment description: (Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files [Checked in: Comment 8] → (Av3) Stop trying to package MSVC dlls when WIN32_REDIST_DIR isn't set, Sort '[xpcom]' files [Checked in: Comment 8 & 10 & 9]
See Also: → 881221
You need to log in before you can comment on or make changes to this bug.