Last Comment Bug 735680 - Update icons for webapps doorhanger notification
: Update icons for webapps doorhanger notification
Status: RESOLVED FIXED
[qa+]
: icon
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Stephen Horlander [:shorlander]
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 08:18 PDT by Marco Bonardo [::mak]
Modified: 2012-05-10 14:52 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WebApp Notification Icon - 64px (2.87 KB, image/png)
2012-04-04 11:38 PDT, Stephen Horlander [:shorlander]
no flags Details
WebApp Notificaion Icon (OSX) - 16px (412 bytes, image/png)
2012-04-04 11:39 PDT, Stephen Horlander [:shorlander]
no flags Details
WebApp Notificaion Icon (Windows) - 16px (641 bytes, image/png)
2012-04-04 11:40 PDT, Stephen Horlander [:shorlander]
no flags Details
WebApp Notificaion Icon (Linux) - 16px (475 bytes, image/png)
2012-04-04 11:41 PDT, Stephen Horlander [:shorlander]
no flags Details
New icons (14.01 KB, patch)
2012-04-12 16:09 PDT, :Felipe Gomes (needinfo me!)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] 2012-03-14 08:18:02 PDT
Looks like bug 697006 landed a new locationbar icon for webapps, and it is starting to appear to users.
The problem is that this icon at 16x16 looks scary, I thought it was some sort of malware.  Shorlander and Wesj had similar thoughts on IRC.

Afaict, apart being really scary, clicking on the icon doesn't do anything, sometimes the key replaces it but still does nothing. I couldn't really figure out what it was till shorlander found it.

This is the icon:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/webapps-16.png
May actually look like a scorpion or an evil mask, nothing positive and nice as an app :)

I think this icon should not be presented to users as it is.
Comment 1 [:fabrice] Fabrice Desré 2012-03-14 08:38:01 PDT
When did it appear to you? This should only occur when installing a web app with the mozApps api.
Comment 2 Stephen Horlander [:shorlander] 2012-03-14 08:38:45 PDT
(In reply to Fabrice Desré [:fabrice] from comment #1)
> When did it appear to you? This should only occur when installing a web app
> with the mozApps api.

I got this during an add-on install next to the add-ons puzzle piece icon.
Comment 3 Marco Bonardo [::mak] 2012-03-14 08:43:40 PDT
I was on tbpl page, nothing related to webapps
Comment 4 Stephen Horlander [:shorlander] 2012-03-14 08:47:57 PDT
(In reply to Marco Bonardo [:mak] from comment #0)
> This is the icon:
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/
> webapps-16.png
> May actually look like a scorpion or an evil mask, nothing positive and nice
> as an app :)

The icon to represent apps is currently in progress, so this is a placeholder regardless. But eventually we will need icons in the style of the other notification icons for various platforms. We should wait for a final apps icon first though.

It would be appreciated if I could please be notified of new icons being checked :)

Thanks!
Comment 5 Stephen Horlander [:shorlander] 2012-03-14 08:50:06 PDT
(In reply to Fabrice Desré [:fabrice] from comment #1)
> When did it appear to you? This should only occur when installing a web app
> with the mozApps api.

It seems to be appearing next to all notification icons (password, geolocation, etc) http://cl.ly/0D1C11231i3G2H171e0B
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-14 09:24:50 PDT

*** This bug has been marked as a duplicate of bug 735517 ***
Comment 7 Marco Bonardo [::mak] 2012-03-14 10:28:26 PDT
Reopening to track the need for a better icon
Comment 8 Stephen Horlander [:shorlander] 2012-04-04 11:38:33 PDT
Created attachment 612271 [details]
WebApp Notification Icon - 64px
Comment 9 Stephen Horlander [:shorlander] 2012-04-04 11:39:46 PDT
Created attachment 612272 [details]
WebApp Notificaion Icon (OSX) - 16px

Default and Pressed/Open States
Comment 10 Stephen Horlander [:shorlander] 2012-04-04 11:40:42 PDT
Created attachment 612273 [details]
WebApp Notificaion Icon (Windows) - 16px

Default, Hover and Pressed/Open states
Comment 11 Stephen Horlander [:shorlander] 2012-04-04 11:41:05 PDT
Created attachment 612274 [details]
WebApp Notificaion Icon (Linux) - 16px
Comment 12 Stephen Horlander [:shorlander] 2012-04-04 11:41:45 PDT
Thanks to Martell for the icons! :)
Comment 13 :Felipe Gomes (needinfo me!) 2012-04-12 16:09:17 PDT
Created attachment 614598 [details] [diff] [review]
New icons

Just replacing previous files with new icons.
I cropped them to the grayscale version of each (except for Linux) and pngcrush'ed again
Comment 14 :Felipe Gomes (needinfo me!) 2012-04-12 18:31:03 PDT
sry for the typo in the commit message, "wbapps" :S

https://hg.mozilla.org/integration/mozilla-inbound/rev/0209dfc83681
Comment 15 Marco Bonardo [::mak] 2012-04-13 04:35:01 PDT
https://hg.mozilla.org/mozilla-central/rev/0209dfc83681
Comment 16 Alfred Kayser 2012-04-13 07:05:23 PDT
Nice icons!
However for the 16 icon version, why are these 48x16 for windows when only the first 16x16 is used? Or will it be used in later stage?
Comment 17 Jason Smith [:jsmith] 2012-05-07 18:24:53 PDT
For verification - When are the rocket ship icons other than the red ones used? So far I've only seen the red ones used in the code. The two places I've seen these icons used are:

- Doorhanger notification
- App does not specify an icon

I believe those two use cases are correct, but can someone confirm.
Comment 18 :Felipe Gomes (needinfo me!) 2012-05-07 18:28:52 PDT
The small icons are used in the doorhanger notifications: they show up in the location bar and are what the doorhanger points to. Only the gray ones are used now, the colored are for future Firefox theme work.

Note You need to log in before you can comment on or make changes to this bug.