Closed Bug 735688 Opened 10 years ago Closed 10 years ago

TB-IM: Not open the OAuth Window for Twitter

Categories

(Thunderbird :: Instant Messaging, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 756277

People

(Reporter: tetsuharu, Unassigned)

References

Details

Attachments

(1 file)

Enviroment:
・Windows 7 (x64)
・Thunderbird Daily buid: http://hg.mozilla.org/mozilla-central/rev/c71845b3b2a6

STR:
0. None registered chat accout
1. Add Twitter accout

Result:
Thunderbird does not open an OAuth window for Twitter.
If I toggle "Connect" button, Thunderbird does not open it too.

Note:
The reproduce of this bug may be severe.
In some case, Thunderbird shows the OAuth window normally after I restart Thunderbird. (Usually)
But other cases, Thunderbird cannot show the OAuth window if I toggle "Connect" button or restart with enable to "Sign-on at startup".
Blocks: 714733
As the result of continue to find a step to reproduce, if I add twitter account & abort an initiating auth & retry to connect, Thunderbird shows the OAuth window without restarting.

The STR of this bug is difficult...
I remember that try-server builds of bug 714733 shows the OAuth window immediately when I add the twitter account.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(In reply to OHZEKI Tetsuharu [:saneyuki_s] from comment #1)
> As the result of continue to find a step to reproduce, if I add twitter
> account & abort an initiating auth & retry to connect, Thunderbird shows the
> OAuth window without restarting.
> 
> The STR of this bug is difficult...
> I remember that try-server builds of bug 714733 shows the OAuth window
> immediately when I add the twitter account.

So are we experiencing the same thing?  I just discovered this functionality and tried to check it out.  I am not sure what is supposed to open the OAuth window: Thunderbird or my default/sensible browser?  I am a pain, and I use Nightly FF build with no-remote, and stable as well (left as default), so clicking on links usually throws Thunderbird errors because I was too lazy to configure my defaults in Windows 7 (32-bit).  So it that an issue, or is the browser supposed to throw a window?
(In reply to alharaka from comment #3)
> I am not sure what is supposed to open the OAuth
> window: Thunderbird or my default/sensible browser?

Thunderbird.
(In reply to alharaka from comment #2)
> Created attachment 607504 [details]
> Screenshot to confirm we are experiencing the same thing.

Yes. Its screenshot may describe the same thing.
This bug is that Thunderbird sometimes does not open OAuth window to *Thunderbird*.
At first, I did not find an obvious step to reproduce. I changed this bug's status to UNCONFIRMED until other user report to experience the same bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I saw the bug once. I saw it again after a restart, so I thought I was going to be able to debug it, but it (the bug) disappeared at the second restart, so I still don't have any idea of what's going on...
(In reply to Florian Quèze from comment #6)
> I saw the bug once. I saw it again after a restart, so I thought I was going
> to be able to debug it, but it (the bug) disappeared at the second restart,
> so I still don't have any idea of what's going on...

For me, a subsequent restart has not successfully cleared the issue.  I can recreate after subsequent killing and execution of the process.  So how should I proceed to help debug this thing?

Also of note, I have two Twitter accounts (as evidenced in the screenshot).  Could that be causing a problem?
(In reply to alharaka from comment #7)
> 
> Also of note, I have two Twitter accounts (as evidenced in the screenshot). 
> Could that be causing a problem?

On my environment, I could reproduce this bug with using 1 Twitter account.
I seem the number of account would not be related to this problem.
Same problem here, restarting doesn’t help.
I tried a fresh profile and some old ones, in none of those a dialog is opend. No entries in the error console.
Depends on: 756277
I can confirm that this issue has been fixed by the patch from bug 756277.

Here is how I verified:
On my linux debug build I could reproduce reliably last week that the OAuth dialog didn't open immediately after creating the account if the "connect this account now" checkbox was checked on the last step the chat account wizard.

I updated the my debug build on that machine, building from a tree pulled just before the patch landed.
I tested 3 times that I could still reproduce with an up to date build with the steps to reproduce I found last week. I could reproduce successfully all of the 3 times with exactly the same steps (however if the twitter account is connected from the "Chat Account status" dialog or automatically at startup the OAuth dialog appeared correctly).

Then I applied the patch, recompiled and retested 3 times. The OAuth dialog appeared correctly the 3 times.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 756277
You need to log in before you can comment on or make changes to this bug.