utils.talosError: 'failed to initialize browser'

RESOLVED DUPLICATE of bug 686085

Status

RESOLVED DUPLICATE of bug 686085
7 years ago
6 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I know that it fails in this try block [1] and I *suspect* that the problem happens on the first few lines:
   594       mytest = TTest(browser_config['remote'])
   595       browser_dump, counter_dump, print_format = mytest.runTest(browser_config, test)
   596       utils.debug("Received test results: " + " ".join(browser_dump))
   597       results[testname] = [browser_dump, counter_dump, print_format]

The TTest class is defined in here [2].
I assume so because I don't see the message "Received test results" on the log.
I also believe the "except" clause is reached:
 self.cleanupAndCheckForCrashes(browser_config, profile_dir) [3]
because we try to grab the minidumps [4].

I don't understand why the timestamps are so far apart when the step only run for 20 mins. [5]

[1] http://hg.mozilla.org/build/talos/file/default/talos/run_tests.py#l593
[2] http://mxr.mozilla.org/build/source/talos/talos/ttest.py#69
[3] http://mxr.mozilla.org/build/source/talos/talos/ttest.py#453
[4] http://mxr.mozilla.org/build/source/talos/talos/ttest.py#177
[5] http://mxr.mozilla.org/build/source/talos/talos/bcontroller.py#215

########################################
python run_tests.py --noisy local.yml
 in dir /builds/tegra-028/test/../talos-data/talos/ (timeout 21600 secs)
 watching logfiles {}
 argv: ['python', 'run_tests.py', '--noisy', 'local.yml']
 environment:
  PATH=/opt/local/bin:/opt/local/sbin:/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/tegra-028/talos-data/talos
  SUT_IP=10.250.49.15
  SUT_NAME=tegra-028
  __CF_USER_TEXT_ENCODING=0x1F6:0:0
 closing stdin
 using PTY: False
reconnecting socket
RETURN:<a href = "http://hg.mozilla.org/mozilla-central/rev/d381ce0baac0">rev:d381ce0baac0</a>
tegra-028: 
		Started Wed, 14 Mar 2012 10:04:19
Running test tdhtml: 
		Started Wed, 14 Mar 2012 10:04:19
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/getInfo.html'
reconnecting socket
DeviceManager: error pulling file '/mnt/sdcard/tests/browser_output.txt': No such file or directory
reconnecting socket
pushing directory: /tmp/tmpAslexR/profile to /mnt/sdcard/tests/profile
NOISE: __startBeforeLaunchTimestamp1331744676794__endBeforeLaunchTimestamp
NOISE: __startAfterTerminationTimestamp1331745830613__endAfterTerminationTimestamp
reconnecting socket
getting files in '/mnt/sdcard/tests/profile/minidumps/'
Failed tdhtml: 
		Stopped Wed, 14 Mar 2012 10:23:52
FAIL: Busted: tdhtml
FAIL: failed to initialize browser
Traceback (most recent call last):
  File "run_tests.py", line 666, in <module>
    main()
  File "run_tests.py", line 663, in main
    test_file(arg, options, parser.parsed)
  File "run_tests.py", line 604, in test_file
    raise e
utils.talosError: 'failed to initialize browser'
program finished with exit code 1
elapsedTime=1173.768701
########################################
This seems related:

https://tbpl.mozilla.org/php/getParsedLog.php?id=12693305&tree=Fx-Team&full=1

Rev3 WINNT 6.1 fx-team talos chrome.2 on 2012-06-15 04:05:48 PDT for push 42d4a34aced6

Running test tscroll.2: 
		Started Fri, 15 Jun 2012 04:05:50
NOISE: __browserInfo
NOISE: browser_name:Firefox
NOISE: browser_version:16.0a1
NOISE: buildID:20120615020927
NOISE: __browserInfo__metrics	Screen width/height:1024/768
NOISE: 	colorDepth:24
NOISE: 	Browser inner width/height: 1010/601
NOISE: __metrics
Failed tscroll.2: 
		Stopped Fri, 15 Jun 2012 04:26:01
FAIL: Busted: tscroll.2
FAIL: initialization timed out
Traceback (most recent call last):
  File "run_tests.py", line 580, in run_tests
    browser_dump, counter_dump, print_format = mytest.runTest(browser_config, test)
  File "c:\talos-slave\talos-data\talos\ttest.py", line 261, in runTest
    self.initializeProfile(profile_dir, browser_config)
  File "c:\talos-slave\talos-data\talos\ttest.py", line 133, in initializeProfile
    if not self._ffsetup.InitializeNewProfile(profile_dir, browser_config):
  File "c:\talos-slave\talos-data\talos\ffsetup.py", line 288, in InitializeNewProfile
    raise talosError("initialization timed out")
talosError: 'initialization timed out'
Traceback (most recent call last):
  File "run_tests.py", line 640, in ?
    main()
  File "run_tests.py", line 637, in main
    run_tests(parser.config)
  File "run_tests.py", line 591, in run_tests
    raise e
utils.talosError: 'initialization timed out'
program finished with exit code 1
elapsedTime=1214.842000

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686085
You need to log in before you can comment on or make changes to this bug.