Closed Bug 686085 Opened 9 years ago Closed 5 years ago

Intermittent Android "talosError: 'failed to initialize browser'"

Categories

(Testing :: Talos, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [android_tier_1])

+++ This bug was initially created as a clone of Bug #662127 +++

Every Talos suite, far as I know, and absolutely nothing in the log to indicate whether it's browser code, or harness code, or buildbot code, or what. Randomly chosen from among the four on my last push:

https://tbpl.mozilla.org/php/getParsedLog.php?id=6357886
Android Tegra 250 mozilla-inbound talos remote-tdhtml on 2011-09-09 18:41:29 PDT for push d09ca67df777

========= Started 'python run_tests.py ...' warnings (results: 1, elapsed: 45 secs) ==========
python run_tests.py --noisy local.yml
 in dir /builds/tegra-062/test/../talos-data/talos/ (timeout 21600 secs)
 watching logfiles {}
 argv: ['python', 'run_tests.py', '--noisy', 'local.yml']
 environment:
  PATH=/opt/local/bin:/opt/local/sbin:/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/tegra-062/talos-data/talos
  SUT_IP=10.250.49.49
  SUT_NAME=tegra-062
  __CF_USER_TEXT_ENCODING=0x1F6:0:0
 closing stdin
 using PTY: False
reconnecting socket
RETURN:s: tegra-062
RETURN:id:20110909183130
RETURN:<a href = "http://hg.mozilla.org/integration/mozilla-inbound/rev/d09ca67df777">rev:d09ca67df777</a>
tegra-062: 
		Started Fri, 09 Sep 2011 18:47:35
Running test tdhtml: 
		Started Fri, 09 Sep 2011 18:47:35
reconnecting socket
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/getInfo.html'
DeviceManager: error pulling file: No such file or directory
reconnecting socket
pushing directory: /tmp/tmpqxR0DA/profile to /mnt/sdcard/tests/profile
NOISE: __startSecondTimestamp1315619298748__endSecondTimestamp
Failed tdhtml: 
		Stopped Fri, 09 Sep 2011 18:48:20
FAIL: Busted: tdhtml
FAIL: failed to initialize browser
Completed test tdhtml: 
		Stopped Fri, 09 Sep 2011 18:48:20
RETURN: cycle time: 00:00:45<br>
tegra-062: 
		Stopped Fri, 09 Sep 2011 18:48:20
Sending results: 
		Started Fri, 09 Sep 2011 18:48:20
RETURN:<br>
RETURN:<p style="font-size:smaller;">Details:<br>|</p>
Completed sending results: 
		Stopped Fri, 09 Sep 2011 18:48:20
program finished with exit code 0
elapsedTime=45.649192
TinderboxPrint:s: tegra-062

TinderboxPrint:id:20110909183130

TinderboxPrint:<a href = "http://hg.mozilla.org/integration/mozilla-inbound/rev/d09ca67df777">rev:d09ca67df777</a>

TinderboxPrint:FAIL: Busted: tdhtml

TinderboxPrint:FAIL: failed to initialize browser

TinderboxPrint: cycle time: 00:00:45<br>

TinderboxPrint:<br>

TinderboxPrint:<p style="font-size:smaller;">Details:<br>|</p>
======== Finished 'python run_tests.py ...' warnings (results: 1, elapsed: 45 secs) ========
clint, joel: Further up the logs, I see:

...
FIRE PROC: 'org.mozilla.fennec  -profile /mnt/sdcard/tests/profile http://bm-remote.build.mozilla.org/getInfo.html'
DeviceManager: error pulling file: No such file or directory
...

Would this cause the reported error ?
:joduinn, yes that is the root cause of this.  It seems we fixed this, but it is now showing up in all test types (browser-chrome, mochitest, reftest).  I have tried hundreds of times to reproduce this on my tegra last week unsuccesfully.

It was much easier when I could reproduce the problem, then I could provide a lot of useful information.  Since we an easily reproduce this in a live buildbot environment, would it be a good idea to put a lot of diagnostic information into our tools to collect logcat, process listings, memory information, etc...?  I like the idea, but it might really confuse people looking at the logs.
https://tbpl.mozilla.org/php/getParsedLog.php?id=6618323&tree=Mozilla-Inbound
Summary: Constant "failed to initialize browser" running Talos on Android Tegras → Intermittent "failed to initialize browser" running Talos on Android Tegras
Depends on: 690311
Assignee: nobody → bear
I kept this bug in my queue thinking that mozharness would arrive from the glorious future or I would have an epiphany about how to solve this or WW4 would strike...

removing from my queue so this can be triaged
Assignee: bear → nobody
May or may not have always been yours, but after the March 12th bustage starting with comment 188, it's yours.

https://tbpl.mozilla.org/php/getParsedLog.php?id=10065106&tree=Mozilla-Inbound
Component: Talos → General
Product: Testing → Fennec Native
QA Contact: talos → general
blocking-fennec1.0: --- → -
Depends on: 690311
https://tbpl.mozilla.org/php/getParsedLog.php?id=14230169&tree=Firefox
Component: General → Talos
Product: Firefox for Android → Testing
Depends on: 790602
Summary: Intermittent "failed to initialize browser" running Talos on Android Tegras → Intermittent Android "talosError: 'failed to initialize browser'"
Duplicate of this bug: 735809
Depends on: 797324