Last Comment Bug 735916 - With 'javascript.options.mem.log' enabled GC status messages are broken
: With 'javascript.options.mem.log' enabled GC status messages are broken
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla14
Assigned To: Bill McCloskey (:billm)
:
Mentors:
: 735994 (view as bug list)
Depends on:
Blocks: 531396
  Show dependency treegraph
 
Reported: 2012-03-14 16:28 PDT by Bill McCloskey (:billm)
Modified: 2012-03-15 08:24 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.31 KB, patch)
2012-03-14 16:28 PDT, Bill McCloskey (:billm)
terrence: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-03-14 16:28:16 PDT
Created attachment 606021 [details] [diff] [review]
fix

We're passing a wide in as a %s argument, so only the first character appears.
Comment 1 Terrence Cole [:terrence] 2012-03-14 16:37:04 PDT
Comment on attachment 606021 [details] [diff] [review]
fix

Review of attachment 606021 [details] [diff] [review]:
-----------------------------------------------------------------

Whoops!  Thanks for fixing this.  I really should have checked more thoroughly after changing that to an nsString at the last minute.
Comment 3 Andrew McCreight [:mccr8] 2012-03-15 05:43:32 PDT
*** Bug 735994 has been marked as a duplicate of this bug. ***
Comment 4 Marco Bonardo [::mak] 2012-03-15 08:24:40 PDT
https://hg.mozilla.org/mozilla-central/rev/09f0b5bc3301

Note You need to log in before you can comment on or make changes to this bug.