Closed Bug 735994 Opened 8 years ago Closed 8 years ago

Garbage collection console messages are broken

Categories

(Core :: JavaScript Engine, defect)

14 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 735916

People

(Reporter: david.guo, Unassigned)

References

Details

(Keywords: regression)

The nightly builds on March 14 and onwards have a bug in the error console with regards to the garbage collection messages.

To reproduce:
1) Ensure that the preference javascript.options.mem.log is set to true
2) Open the Error Console
3) Wait for a GC console message

Expected (of the following variant):
> GC(T+0.0) TotalTime: 254.2ms, Type: global, MMU(20ms): 0%, MMU(50ms): 0%, 
>            Reason: MAYBEGC, +chunks: 0, -chunks: 0 mark: 160.2, 
>            mark-roots: 5.8, mark-other: 3.6, sweep: 92.0, sweep-obj: 7.9, 
>            sweep-string: 12.2, sweep-script: 1.2, sweep-shape: 6.7, 
>            discard-code: 6.8, discard-analysis: 46.4, xpconnect: 3.5, 
>            deallocate: 0.4

Actual:
> GC(T+#) T
Henrik believes that it has something to do with this commit:

http://hg.mozilla.org/mozilla-central/rev/4fa4374cf9de#l1.95
It's a regression from the API changes on bug 531396.
Blocks: 531396
Keywords: regression
OS: Mac OS X → All
Hardware: x86_64 → All
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735916
You need to log in before you can comment on or make changes to this bug.