Check For Updates should do just that

RESOLVED DUPLICATE of bug 600500

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 600500
6 years ago
6 years ago

People

(Reporter: Booze, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Using FF901.

When I go to the ABOUT dialog, and then click on "Check for Updates" Firefox starts to download update automatically (and of course, once its downloaded it applies the update without further interaction). It did this, while using 9.0.1, for 10.0.2 which was available yesterday, and I just tried it with a clean profile and it does it with 11.0 which is now available. I've had to delete active-update.xml and the 0 in the update folder to prevent it from updating itself.

This is same as Bug 690964. That bug degenerated into a discussion about minor-vs-major updates and wether they should be applied automatically, and the original bug was never addressed. -No- updates should be applied automatically when someone clicks on CHECK for updates, minor OR major. User just wants to check...

I'd like to point out that I have auto-updates disabled (who knows, this might be part of the problem):

user_pref("app.update.auto", false);
user_pref("app.update.enabled", false);
user_pref("browser.search.update", false);
user_pref("extensions.update.enabled", false);
user_pref("extensions.update.notifyUser", false);
user_pref("extensions.update.autoUpdateDefault", false);



Expected results:

From ABOUT dialog, "Check for Updates" should do just that, CHECK for updates, and present some requester to allow user to proceed if he wants to select some update to apply, or cancel if he does not want to update at this point. IIRC Firefox used to do that.
(Reporter)

Comment 1

6 years ago
PS:

"and of course, once its downloaded it applies the update without further interaction" --> This is not entirely correct, user does need to restart ffox.
(Reporter)

Comment 2

6 years ago
Oops, duplicate of Bug 600500.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 600500
You need to log in before you can comment on or make changes to this bug.