Last Comment Bug 736035 - Chat accounts sometimes disappear from the Account Settings dialog
: Chat accounts sometimes disappear from the Account Settings dialog
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- major (vote)
: Thunderbird 14.0
Assigned To: Florian Quèze [:florian] [:flo] (PTO until August 29th)
:
Mentors:
Depends on:
Blocks: 714733
  Show dependency treegraph
 
Reported: 2012-03-15 03:58 PDT by Florian Quèze [:florian] [:flo] (PTO until August 29th)
Modified: 2012-04-02 04:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Recreate the missing chat accounts (2.38 KB, patch)
2012-03-22 08:58 PDT, Florian Quèze [:florian] [:flo] (PTO until August 29th)
mozilla: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-15 03:58:01 PDT
(Florian Quèze in bug 714733 comment #1)

> - Sometimes the "Account Settings..." dialog loses track of *all* IM
> accounts. The accounts are still listed in the "Instant messaging accounts
> status" dialog though. I've seen this only once, but I know Jb has also
> suffered from this problem. We do not know the steps to reproduce so I
> currently can't fix it, if anybody can find steps to reproduce, that would
> be awesome.
Comment 1 David :Bienvenu 2012-03-15 08:03:07 PDT
yeah, this is happening to me - it seems to be permanent, not intermittent (by sometimes, do you mean "for some users" or "in some profiles"?)
Comment 2 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-15 08:10:46 PDT
Once they have disappeared they don't reappear. By sometimes I mean "some unknown situation causes it to happen". It happened twice to me in 3 months. I know it happened at least twice to Jb too.
It's a serious bug, but I don't have any steps to reproduce, so at this point I can just hope that some tester will notice it soon enough after it happened, so that he will remember what he has done immediately before and will be able to tell us.

If we still don't have any idea of the cause and approach the date of the aurora->beta merge, I guess we can hide the issue by recreating the mailnews accounts when at startup there are chat accounts without associated mailnews account, but I would really like to avoid hiding the brokenness under the carpet.
Comment 3 David :Bienvenu 2012-03-15 08:12:58 PDT
would running a version w/o chat after setting up the accounts cause this?
Comment 4 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-16 05:25:34 PDT
(In reply to David :Bienvenu from comment #3)
> would running a version w/o chat after setting up the accounts cause this?

It does! Thanks! :-)

It immediately "cleans up" the mail.accountmanager.accounts pref of all accounts it can't recognize. The mail.server.server<n>.* prefs aren't removed immediately, but if the user creates another account, they are overwritten.

So I guess recreating the mailnews accounts for existing chat accounts that don't have one at startup is the way to go...
If there are other ways to reproduce this bug, it will hide (rather than fix) them though.
Comment 5 David :Bienvenu 2012-03-16 06:43:04 PDT
(In reply to Florian Quèze from comment #4)
> If there are other ways to reproduce this bug, it will hide (rather than
> fix) them though.
Yes, though there's no information loss when reconstructing the accounts, is there? I think recreating them is the right thing to do, if there are other ways to reproduce this bug.
Comment 6 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-22 08:58:07 PDT
Created attachment 608346 [details] [diff] [review]
Recreate the missing chat accounts

(In reply to David :Bienvenu from comment #5)

> Yes, though there's no information loss when reconstructing the accounts, is
> there?

The only loss that I can imagine is the order of the accounts in the Account Settings dialog. I don't think that matters.
Comment 7 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-23 04:17:09 PDT
http://hg.mozilla.org/comm-central/rev/37540bbaf204
Comment 8 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-03-30 06:00:16 PDT
Comment on attachment 608346 [details] [diff] [review]
Recreate the missing chat accounts

[Approval Request Comment]
This fix is required to let users go back and forth between Tb builds with and without the IM feature without them having their accounts half removed when they are back on a build with IM.
Comment 9 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-04-02 04:07:57 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/0742ec41585a

Note You need to log in before you can comment on or make changes to this bug.