L10n repacks broken with Instant Messaging landing

RESOLVED FIXED in Thunderbird 14.0

Status

Thunderbird
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Trunk
Thunderbird 14.0

Thunderbird Tracking Flags

(thunderbird13 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 606172 [details] [diff] [review]
The fix

When performing l10n repacks, we're seeing:

make[3]: Entering directory `/buildbot/comm-central-linux-l10n-full/build/comm-central/chat/components/public'
/buildbot/comm-central-linux-l10n-full/build/comm-central/mozilla/config/nsinstall -D ../../../mozilla/dist/idl
/buildbot/comm-central-linux-l10n-full/build/comm-central/mozilla/config/nsinstall -D ../../../mozilla/dist/idl
imIAccount.idl
/tools/python/bin/python2.5 -u ../../../mozilla/config/pythonpath.py \
	  -I../../../mozilla/other-licenses/ply \
	  -I../../../mozilla/xpcom/idl-parser \
	  ../../../mozilla/xpcom/idl-parser/header.py --cachedir=../../../mozilla/xpcom/idl-parser -I. -I../../../mozilla/dist/idl imIAccount.idl -d .deps/imIAccount.h.pp -o _xpidlgen/imIAccount.h
Traceback (most recent call last):
  File "../../../mozilla/config/pythonpath.py", line 52, in <module>
    main(sys.argv[1:])
  File "../../../mozilla/config/pythonpath.py", line 44, in main
    execfile(script, frozenglobals)
  File "../../../mozilla/xpcom/idl-parser/header.py", line 531, in <module>
    idl.resolve(options.incdirs, p)
  File "/buildbot/comm-central-linux-l10n-full/build/comm-central/mozilla/xpcom/idl-parser/xpidl.py", line 318, in resolve
    p.resolve(self)
  File "/buildbot/comm-central-linux-l10n-full/build/comm-central/mozilla/xpcom/idl-parser/xpidl.py", line 288, in resolve
    raise IDLError("File '%s' not found" % self.filename, self.location)
xpidl.IDLError: error: File 'nsISupports.idl' not found, imIAccount.idl line 38:0
#include "nsISupports.idl"
^
make[3]: *** [_xpidlgen/imIAccount.h] Error 1

The issue is we're repacking in chat/ not chat/locales.
Attachment #606172 - Flags: review?(florian)
Comment on attachment 606172 [details] [diff] [review]
The fix

Oops, sorry about that, thanks for fixing it!
Attachment #606172 - Flags: review?(florian) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 606172 [details] [diff] [review]
The fix

[Triage Comment]
We need this for aurora as well as chat is there.
Attachment #606172 - Flags: approval-comm-aurora+
(Assignee)

Comment 3

5 years ago
Checked in:

http://hg.mozilla.org/comm-central/rev/7b9bb99a0dc9
http://hg.mozilla.org/releases/comm-aurora/rev/d318be5f503a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-thunderbird13: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 14.0
You need to log in before you can comment on or make changes to this bug.