Last Comment Bug 736316 - Components.utils.getGlobalForObject should unwrap cross-compartment wrappers
: Components.utils.getGlobalForObject should unwrap cross-compartment wrappers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Bobby Holley (busy)
:
Mentors:
: 613315 (view as bug list)
Depends on:
Blocks: cpg
  Show dependency treegraph
 
Reported: 2012-03-15 16:49 PDT by Bobby Holley (busy)
Modified: 2012-04-13 17:03 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Components.utils.getGlobalForObject should unwrap cross-compartment wrappers. v1 (1.53 KB, patch)
2012-03-15 16:51 PDT, Bobby Holley (busy)
khuey: review+
Details | Diff | Review

Description Bobby Holley (busy) 2012-03-15 16:49:12 PDT
Wrappers are parented to their compartment's global, so we need to unwrap if we want to give callers what they expect. Patch coming right up.
Comment 1 Bobby Holley (busy) 2012-03-15 16:51:48 PDT
Created attachment 606405 [details] [diff] [review]
Components.utils.getGlobalForObject should unwrap cross-compartment wrappers. v1

Attaching a patch. Flagging khuey for review because, well, I've already given a lot to Blake. ;-)
Comment 2 Bobby Holley (busy) 2012-03-15 17:13:33 PDT
Pushed this to try:

https://tbpl.mozilla.org/?tree=Try&rev=30b08591d306
Comment 3 Bobby Holley (busy) 2012-03-15 19:48:27 PDT
Looks green - pushed to m-i: http://hg.mozilla.org/integration/mozilla-inbound/rev/3cbfbd2dad36
Comment 4 Marco Bonardo [::mak] 2012-03-16 06:33:37 PDT
https://hg.mozilla.org/mozilla-central/rev/3cbfbd2dad36
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-13 17:03:32 PDT
*** Bug 613315 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.