Closed Bug 736376 Opened 9 years ago Closed 8 years ago

B2G SMS : SMS Received event unresponsive

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 735536

People

(Reporter: jhammink, Unassigned)

References

Details

Attachments

(1 file)

Latest pull (gonk/gecko/Gaia); 3/15

B2G Commit: b0d64debd94dc3e7375b9aac9d64f49e9f6e0032

It seems like there might be a regression; the SMS event listener for "received" SMSes has stopped working.

To test this I used the attached marionette test with the following command:
python runtests.py --address localhost:2828 /home/mozilla/Documents/othertests/test_sms_event.js

adb logcat | grep sms returns the following:
I/Gecko   ( 2613): SmsDatabaseService: Going to store {"delivery":"sent","sender":null,"receiver":"16509965746","body":"eat food","timestamp":1331870281502,"id":5}
I/Gecko   ( 2613): SmsDatabaseService: Going to store {"delivery":"received","sender":"+16509965746","receiver":null,"body":"eat food","timestamp":1331827062000,"id":6}

but it appears that the actual event received is never fired (neither alert nor log command is sent) in the event handler block.
Attachment #606447 - Attachment description: A simple api test for the event handler → A simple api test for the event handler; script sends message to own number; alerts and logs on received event handler
I don't know if it's related but since a few days I see:

Error: [Exception... "This error occurred because an operation was not allowed on an object. A retry of the same operation would fail unless the cause of the error is corrected."  code: "2" nsresult: "0x80660002 (NS_ERROR_DOM_INDEXEDDB_NON_TRANSIENT_ERR)"  location: "file:///home/vivien/Devel/mozilla/b2g/desktop/build/dist/bin/components/SmsDatabaseService.js Line: 180"]
Source File: file:///home/vivien/Devel/mozilla/b2g/desktop/build/dist/bin/components/SmsDatabaseService.js
Line: 180
(In reply to Vivien Nicolas (:vingtetun) from comment #1)
> I don't know if it's related but since a few days I see:
> 
> Error: [Exception... "This error occurred because an operation was not
> allowed on an object. A retry of the same operation would fail unless the
> cause of the error is corrected."  code: "2" nsresult: "0x80660002
> (NS_ERROR_DOM_INDEXEDDB_NON_TRANSIENT_ERR)"  location:
> "file:///home/vivien/Devel/mozilla/b2g/desktop/build/dist/bin/components/
> SmsDatabaseService.js Line: 180"]
> Source File:
> file:///home/vivien/Devel/mozilla/b2g/desktop/build/dist/bin/components/
> SmsDatabaseService.js
> Line: 180

Yep, that's bug 735536 and I'm *pretty* sure the cause of this.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 735536
You need to log in before you can comment on or make changes to this bug.