Last Comment Bug 736542 - Bug 727637 causes about:newaddon to not show up with magically appearing XPI's
: Bug 727637 causes about:newaddon to not show up with magically appearing XPI's
Status: RESOLVED FIXED
[qa+]
: regression, testcase
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Blair McBride [:Unfocused] (UNAVAILABLE)
:
Mentors:
https://www.alexvincent.us/xpi-tests/...
Depends on:
Blocks: 727637
  Show dependency treegraph
 
Reported: 2012-03-16 11:23 PDT by Alex Vincent [:WeirdAl]
Modified: 2012-05-09 06:47 PDT (History)
8 users (show)
blair: in‑testsuite-
blair: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Patch v1 (2.26 KB, patch)
2012-03-20 06:03 PDT, Blair McBride [:Unfocused] (UNAVAILABLE)
dtownsend: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Alex Vincent [:WeirdAl] 2012-03-16 11:23:22 PDT
Steps to reproduce:
(1) Download the XPI given in the URL field (do NOT install, just download)
(2) Launch FF13 Aurora build to establish profile
(3) Close FF13 Aurora entirely.
(4) Copy the XPI file into the profile's extensions folder.
(5) Launch FF13 again with the same profile.

Expected result:
about:newaddon?id=test-update@alexvincent.us appears in a new tab.

Actual result:
No about:newaddon page appears.
Comment 1 Alex Vincent [:WeirdAl] 2012-03-16 11:27:05 PDT
Backing out the patch from bug 727637 does restore the expected behavior.
Comment 2 Alex Keybl [:akeybl] 2012-03-16 12:31:33 PDT
Tracking for FF13. Given https://bugzilla.mozilla.org/show_bug.cgi?id=727637#c3, it sounds like we should just do the backout.
Comment 3 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-03-20 06:03:26 PDT
Created attachment 607516 [details] [diff] [review]
Patch v1

This undoes bug 727637. Once this lands, I'll re-open bug 727637.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-03-20 08:24:27 PDT
Any idea why that patch broke this?
Comment 5 Dave Townsend [:mossop] 2012-03-20 10:09:05 PDT
Comment on attachment 607516 [details] [diff] [review]
Patch v1

Review of attachment 607516 [details] [diff] [review]:
-----------------------------------------------------------------

Confused why this is breaking but yes let's back it out on aurora
Comment 6 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-03-20 18:54:09 PDT
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #4)
> Any idea why that patch broke this?

Oh, yes - it moved code using |this| into a callback function, so |this| isn't what it expects it to be. Easy fix, but I figured backout was still the safe option for Aurora.
Comment 7 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-03-20 21:44:28 PDT
https://hg.mozilla.org/integration/fx-team/rev/d23d714bc491
Comment 8 Blair McBride [:Unfocused] (UNAVAILABLE) 2012-03-20 21:47:18 PDT
Comment on attachment 607516 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Regression caused by (bug #): bug 727637
User impact if declined: User won't get prompted to enable forgeign-installed addon
Testing completed (on m-c, etc.): Manual
Risk to taking this patch (and alternatives if risky): Minimal risk - back out of bug 727637, which was an optimization, not a behaviour change.
String changes made by this patch: None.
Comment 9 Marco Bonardo [::mak] 2012-03-21 15:54:42 PDT
https://hg.mozilla.org/mozilla-central/rev/d23d714bc491
Comment 10 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-09 15:58:24 PDT
Blair can you do the uplift to aurora on this in the next day or so?
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-09 17:00:32 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/436d4254c0ce
Comment 12 Simona B [:simonab ] -PTO- back Sept 5th 2012-05-09 06:47:08 PDT
Verified on Firefox 13 beta 3 using the steps to reproduce from the description that the about:newaddon page is opened after launching the browser.

Verified as fixed on Windows 7, Ubuntu 12.04 and Mac OS X 10.6:
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20100101 Firefox/13.0

Note You need to log in before you can comment on or make changes to this bug.