Last Comment Bug 736571 - Forwarded mail is incorrectly presented in the plaintext editor.
: Forwarded mail is incorrectly presented in the plaintext editor.
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
Mentors:
Depends on:
Blocks: BigFiles
  Show dependency treegraph
 
Reported: 2012-03-16 12:44 PDT by Mike Hoye
Modified: 2012-03-20 13:39 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
Patch v1 (1.47 KB, patch)
2012-03-16 13:22 PDT, Mike Conley (:mconley) - (needinfo me!)
squibblyflabbetydoo: review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Mike Hoye 2012-03-16 12:44:33 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120316 Firefox/14.0a1
Build ID: 20120316031151

Steps to reproduce:

 
I have this message in my sentmail folder: 


-------------


Hello, folks -

I'm just following up about the tech demo I showed you in late January. Have you come to any conclusions about it?

Thanks,

-- 
Michael Hoye
Bespoke I/O
http://bespokeio.com 

-------------





and when I click "Forward", I see this:

-------------

-------- Original Message --------

Subject: Re: WebFWD Intro

Date: Tue, 14 Feb 2012 11:34:55 -0500

From: Mike Hoye <mhoye@bespokeio.com>

To: Pascal Finette | Mozilla <pfinette@mozilla.com>

CC: Diane Bisgeier <dbisgeier@mozilla.com>


Hello, folks -




Thanks,
















I'm just following up about the tech demo I showed you in late January. Have you come to any conclusions about it?

-- Michael HoyeBespoke I/Ohttp://bespokeio.com

-------------

Because wat.


Actual results:


http://pastebin.mozilla.org/1522640 




Expected results:


Not that.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-03-16 13:22:52 PDT
Created attachment 606708 [details] [diff] [review]
Patch v1

First run at a patch.
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-03-16 13:26:06 PDT
Comment on attachment 606708 [details] [diff] [review]
Patch v1

It's funny - the bug I was seeing before, where carriage returns were being truncated...I'm not seeing it now.  I wonder if the changes made to nsMsgCompose.cpp fixed that.  :/

Regardless, this *seems* to fix things.  Do you have cycles to test / review this, Jim?
Comment 3 Mike Conley (:mconley) - (needinfo me!) 2012-03-17 09:39:43 PDT
A workaround for now is to forward mail using the HTML editor (press and hold Shift while clicking Forward to do this).
Comment 4 rsx11m 2012-03-17 16:55:46 PDT
Confirmed with today's trunk nightly. Forwarding as attachment is broken as well, I'll file a separate bug on that.
Comment 5 rsx11m 2012-03-17 16:56:35 PDT
(confirmed that it's broken badly, I mean, not that the patch works - the message is basically completely rearranged when forwarding inline...)
Comment 6 Jim Porter (:squib) 2012-03-18 13:45:13 PDT
Comment on attachment 606708 [details] [diff] [review]
Patch v1

Review of attachment 606708 [details] [diff] [review]:
-----------------------------------------------------------------

This works for me, too.
Comment 7 Mike Conley (:mconley) - (needinfo me!) 2012-03-18 17:21:34 PDT
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/c212bdbccf39
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2012-03-18 17:26:05 PDT
rsx11m:

When tonight's Daily gets spun out, mind taking it for a spin to see if we've fully resolved the issue?

Thanks!

-Mike
Comment 9 Mike Conley (:mconley) - (needinfo me!) 2012-03-18 18:39:55 PDT
Pushed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/5924288478d6
Comment 10 rsx11m 2012-03-19 06:14:39 PDT
Looking at Thunderbird/14.0a1 BuildID=20120319030043 on Windows 7, the main issue seems to be fixed with today's nightly. The spacing in the forwarded part matches the original spacing. However, there is an additional blank line now at the very top of the plain-text composition window (i.e., three blank lines before the "---Original Message---" heading instead of two as before). This may be unrelated to the bug here though, given that a simple "Write" opens the composition window with an additional blank line on top in the editor which wasn't there before.

Note You need to log in before you can comment on or make changes to this bug.