Last Comment Bug 736724 - New tab Page: Fetch and display thumbnails for sites visited in the current session
: New tab Page: Fetch and display thumbnails for sites visited in the current s...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 14 Branch
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 744388
Blocks: 455553
  Show dependency treegraph
 
Reported: 2012-03-17 05:10 PDT by Klaus Malorny
Modified: 2012-05-02 06:59 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Klaus Malorny 2012-03-17 05:10:28 PDT
When I open a new tab, the about:newtab page is shown with nine boxes referring to recently viewed pages. I had the problem that these boxes were always empty, i.e. no preview was shown. As this worked with a fresh profile, I used try-and-fail to discover the preference setting that was responsible for that. It turned out that the effect was caused by the Preferences -> Privacy tab -> Clear History when Nightly closes -> Settings... -> History/Cache is checked ("privacy.clearOnShutdown.cache" preference).

As I learned that the preview images are stored in the cache, it is reasonable that on the next start the images are no longer available, although this dependency will likely not be clear to a normal Firefox user. Nevertheless, I do not understand that for sites that I have visited in the current session, these preview images are not generated and/or stored and therefore are not displayed if I open a new tab later on in the same session. I consider this as a bug.
Comment 1 Alice0775 White 2012-03-17 06:07:37 PDT
Duplicate or related to Bug 724408
Comment 2 Virgil Dicu [:virgil] [QA] 2012-03-27 02:49:22 PDT
(In reply to Klaus Malorny from comment #0)
> As I learned that the preview images are stored in the cache, it is
> reasonable that on the next start the images are no longer available,
> although this dependency will likely not be clear to a normal Firefox user.

Yes, this is bug 724408

(In reply to Klaus Malorny from comment #0)
>
> Nevertheless, I do not understand that for sites that I have visited in the
> current session, these preview images are not generated and/or stored and
> therefore are not displayed if I open a new tab later on in the same
> session. I consider this as a bug.

I remember this being discussed somewhere(email) and explained as expected (slowness when fetching thumbnails multiple times). I don't think there's an issue for this available anywhere though, so if you won't mind, I'll modify the title to reflect the second part of your post.
Comment 3 Tim Taubert [:ttaubert] 2012-04-12 05:32:28 PDT
Will be fixed by bug 744388.
Comment 4 Tim Taubert [:ttaubert] 2012-05-02 06:59:19 PDT
Fixed by bug 744388.

Note You need to log in before you can comment on or make changes to this bug.