Last Comment Bug 736741 - PGO builds shouldn't be scheduled on DONTBUILD pushes
: PGO builds shouldn't be scheduled on DONTBUILD pushes
Status: RESOLVED DUPLICATE of bug 691675
[pgo]
:
Product: Release Engineering
Classification: Other
Component: General Automation (show other bugs)
: other
: All All
: P5 enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Chris AtLee [:catlee]
Mentors:
Depends on: 691675
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-17 09:26 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2013-08-12 21:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description :Ehsan Akhgari (busy, don't ask for review please) 2012-03-17 09:26:47 PDT
See https://tbpl.mozilla.org/?usebuildbot=1&rev=c7ef262e3024 and many other examples on mozilla-central.
Comment 1 Phil Ringnalda (:philor) 2012-03-17 12:19:30 PDT
Dependent on bug 691675, so good luck with that. They aren't scheduled so much as just thrown at the tree as hard as possible so that they stick to the very tip of it, and deciding DONTBUILD pushes don't count as a change between the last thing that got PGO and now would be one of the jobs of that smarter scheduler.
Comment 2 John Ford [:jhford] 2012-04-26 12:05:18 PDT
It should only not build if *all* pushes between this and the last PGO changeset have DONTBUILD.  This seems like a good optimization to make in the future.
Comment 3 Phil Ringnalda (:philor) 2012-04-26 20:16:45 PDT
Yeah, from a releng standpoint it's interesting for the

abc123 DONTBUILD
def456 DONTBUILD
ghi789 (already had PGO builds)

case where you can skip building entirely, but the reason it was filed is that from a developer standpoint, it is a mistake and a failure and an imposition if in

abc123 DONTBUILD
def456 buildme
ghi789 (already had PGO builds)

you trigger PGO on abc123, instead of triggering it on def456.
Comment 4 Bill Gianopoulos [:WG9s] 2012-06-05 08:27:54 PDT

*** This bug has been marked as a duplicate of bug 691675 ***
Comment 5 Bill Gianopoulos [:WG9s] 2012-06-05 08:29:17 PDT
It will at least only run once now.  That should be sufficient for this and also might catch cases where things are marked DONTBUILD erroneously.
Comment 6 Bill Gianopoulos [:WG9s] 2012-06-05 08:30:45 PDT
This should either be a dupe or WONTFIX.  Just my opinion, I could be wrong! ;-)
Comment 7 Bill Gianopoulos [:WG9s] 2012-06-05 08:40:13 PDT
So, to explain my pint here.  The entire reason for NOT doing PGO builds on each push is that especially on windows they take too long to complete.  The whole idea of the making sure do do one every 4 hours if anything changed is to try to ensure that the nightly build will actually work (since it is a PGO build).

So doing a PGO build if one has not been done for 4 hours even if the only check-ins are marked as not affecting the Firefox builds seems to me to be the right thing to do.  Better to err on the side of doing an unnecessary build than have the nightly fail in my opinion.

Note You need to log in before you can comment on or make changes to this bug.