Last Comment Bug 736819 - statusMessage changes width when in editing mode.
: statusMessage changes width when in editing mode.
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
: 735705 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 03:13 PDT by Richard Marti (:Paenglab)
Modified: 2012-04-02 04:06 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Give statusMessage a width (578 bytes, patch)
2012-03-18 03:18 PDT, Richard Marti (:Paenglab)
florian: review+
bugs: ui‑review+
mozilla: approval‑comm‑aurora+
Details | Diff | Review

Description Richard Marti (:Paenglab) 2012-03-18 03:13:15 PDT
The statusMessage on the chat tool bar changes the width when going in editing mode. This makes jumping every element on the right of the statusMessage.
Comment 1 Richard Marti (:Paenglab) 2012-03-18 03:18:07 PDT
Created attachment 606957 [details] [diff] [review]
Give statusMessage a width

This patch defines a width in the main css file to apply on every theme (also third party). The statusMessage is still flexing as before but doesn't change the width when in editing mode.
Comment 2 Florian Quèze [:florian] [:flo] 2012-03-20 06:52:16 PDT
*** Bug 735705 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Nilsson (:andreasn) 2012-03-20 13:45:16 PDT
Comment on attachment 606957 [details] [diff] [review]
Give statusMessage a width

Finally managed to duplicate the bug with a fresh profile. Patch looks good!
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-03-20 14:43:23 PDT
http://hg.mozilla.org/comm-central/rev/6ed7a2070693 (sorry, I forgot the ui-r= in the commit message)
Comment 5 Florian Quèze [:florian] [:flo] 2012-03-30 06:04:11 PDT
Comment on attachment 606957 [details] [diff] [review]
Give statusMessage a width

[Approval Request Comment]
I think we should take this fix on aurora as having toolbar items jumping around when clicking one of them is really unpleasant.
Comment 6 Florian Quèze [:florian] [:flo] 2012-04-02 04:06:20 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/fbf094f70af4

Note You need to log in before you can comment on or make changes to this bug.