Allow option to tie cache location to profile folder

RESOLVED DUPLICATE of bug 229596

Status

SeaMonkey
OS Integration
RESOLVED DUPLICATE of bug 229596
6 years ago
6 years ago

People

(Reporter: realgrouchy, Unassigned)

Tracking

SeaMonkey 2.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Because the cache location is handled independently from the profile, when you move the profile folder (i.e. by creating a new profile in the desired location and relocating the contents of the old profile) the cache folder is relocated at the old path.

There should be an option in preferences > advanced > cache to have the cache folder always be located as a subfolder of the profile folder. (I would even go so far as to suggest this should be the default)

Comment 1

6 years ago
> There should be an option in preferences > advanced > cache to have the cache folder
> always be located as a subfolder of the profile folder. (I would even go so far as to
> suggest this should be the default)

You really really don't want this as default if your profile is on a networked drive!

Comment 2

6 years ago
Sooo, WONTFIX?
(Reporter)

Comment 3

6 years ago
Okay, forget the comment about making it default. I hadn't considered the networked drive situation, but I'm not on a networked drive, and I would like it as an option. 

I find it a bit strange that on Firefox the cache is always in the profile folder (if I recall correctly from a bug report I read prior to submitting this one), but in SeaMonkey the cache is always in a specified folder. There's no middle ground.

Suppose I move my profile folder over to a new computer, and SeaMonkey is installed in a different location in the new computer than on the old computer (say, "Program Files > SeaMonkey" versus "Windows > Programs > Mozilla > SeaMonkey"). As soon as I fire up the profile, SeaMonkey will recreate the folders and put the cache in the same location as it was on the old computer. 

Or worse, if I move my profile to another computer where I'm using a different username from the old computer, would it not recreate "c:\documents and settings\[OLDUSERNAME]\Application Data\Mozilla\Seamonkey\Profiles\abcdefg.default\cache"? 

This is how I discovered this bug, because I migrated to a new profile folder within the SeaMonkey program folder, but the old abcdefg.default profile folder was recreated after I deleted it, with only the \Cache folder in it. 

That just seems sloppy to me. I've already had to fix this two or three times, and it would be much easier from my situation to be able to toggle to keep it in the profile folder. Networked users can continue to do whatever they feel is groovy for them.

Comment 4

6 years ago
Perhaps "browser.cache.disk.parent_directory" would work for you?
The preference does not exist by default, you need to create it.

Note that you need to specify a full path.
IOW it does not accept a relative path, ..\new_cache, nor environmental variables, %TMP%\new_cache.  Would be nice if it did, then you could set it to a relative location.

http://kb.mozillazine.org/Browser.cache.disk.parent_directory
(Reporter)

Comment 5

6 years ago
(In reply to therube from comment #4)
> Perhaps "browser.cache.disk.parent_directory" would work for you?
> The preference does not exist by default, you need to create it.
> 

That is the element I am having issues with, which I modify through the SeaMonkey Preferences UI. The fact that it doesn't accept either a relative path or environmental variables is the bug.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 229596
You need to log in before you can comment on or make changes to this bug.