Last Comment Bug 737006 - Use internal ply only if needed
: Use internal ply only if needed
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Takanori MATSUURA
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 06:50 PDT by Takanori MATSUURA
Modified: 2012-04-09 17:49 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (9.75 KB, patch)
2012-03-19 06:54 PDT, Takanori MATSUURA
khuey: review+
Details | Diff | Splinter Review
Fix (v2) (13.74 KB, patch)
2012-04-04 07:39 PDT, Takanori MATSUURA
t.matsuu: review+
Details | Diff | Splinter Review
Fix (v3) (13.60 KB, patch)
2012-04-04 12:04 PDT, Takanori MATSUURA
t.matsuu: review+
Details | Diff | Splinter Review
Fix (v4) (13.42 KB, patch)
2012-04-06 04:16 PDT, Takanori MATSUURA
t.matsuu: review+
Details | Diff | Splinter Review

Description Takanori MATSUURA 2012-03-19 06:50:57 PDT
In some parts, $(topsrcdir)/other-licenses/ply is hard-coded.
Comment 1 Takanori MATSUURA 2012-03-19 06:54:47 PDT
Created attachment 607145 [details] [diff] [review]
Fix
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-03 08:33:53 PDT
Comment on attachment 607145 [details] [diff] [review]
Fix

Review of attachment 607145 [details] [diff] [review]:
-----------------------------------------------------------------

Also note that we've added more usage of ply in dom/bindings/Makefile.in. r=me to change those too.

::: config/rules.mk
@@ +1476,5 @@
>  
> +# include internal ply
> +ifndef MOZ_SYSTEM_PLY
> +PLY_INCLUDE=-I$(topsrcdir)/other-licenses/ply
> +endif

Please move this bit to config/config.mk.

::: js/src/config/rules.mk
@@ +1476,5 @@
>  
> +# include internal ply
> +ifndef MOZ_SYSTEM_PLY
> +PLY_INCLUDE=-I$(topsrcdir)/other-licenses/ply
> +endif

Likewise.
Comment 3 Takanori MATSUURA 2012-04-04 07:39:05 PDT
Created attachment 612184 [details] [diff] [review]
Fix (v2)

Addressed review comment.
Carried over r+
Comment 4 Takanori MATSUURA 2012-04-04 12:04:07 PDT
Created attachment 612284 [details] [diff] [review]
Fix (v3)

Fit to the latest m-c.
Carry over r+
Comment 5 Takanori MATSUURA 2012-04-05 04:11:29 PDT
remove checkin-needed keyword because of the fix of bug 741248.
https://hg.mozilla.org/mozilla-central/rev/ed9cbe6a817e

I'll update my patch later.
Comment 6 Takanori MATSUURA 2012-04-06 04:16:18 PDT
Created attachment 612857 [details] [diff] [review]
Fix (v4)

Fit to the latest m-c.
Carry over r+
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-04-06 11:14:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a82e8c2edb29
Comment 8 Matt Brubeck (:mbrubeck) 2012-04-09 10:09:19 PDT
https://hg.mozilla.org/mozilla-central/rev/a82e8c2edb29
Comment 9 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-09 17:44:53 PDT
I reverted the bits of this patch that changed $(PYTHON) $(topsrcdir)/config/pythonpath.py to $(PYTHON_PATH) because they brought bug 741248 back.  All the ply bits are still there though.
Comment 10 Takanori MATSUURA 2012-04-09 17:48:54 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #9)
> I reverted the bits of this patch
Thanks.
It's my mistake because of the discussion of bug 741248 in parallel. :-(
Comment 11 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-04-09 17:49:33 PDT
Don't worry about it.  I should have caught it during review.

Note You need to log in before you can comment on or make changes to this bug.