Last Comment Bug 737301 - make package fails with safe browsing disabled
: make package fails with safe browsing disabled
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Ryan VanderMeulen [:RyanVM]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 713132 738883
  Show dependency treegraph
 
Reported: 2012-03-19 18:41 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2012-03-23 21:35 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.11 KB, patch)
2012-03-19 18:44 PDT, Ryan VanderMeulen [:RyanVM]
khuey: review+
bugzillamozillaorg_serge_20140323: feedback-
Details | Diff | Splinter Review

Description Ryan VanderMeulen [:RyanVM] 2012-03-19 18:41:53 PDT
Due to missing ifdefs, disabling safe browsing now causes build failures due to |make package| failing on errors.
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-03-19 18:44:44 PDT
Created attachment 607407 [details] [diff] [review]
patch
Comment 2 Serge Gautherie (:sgautherie) 2012-03-19 20:08:34 PDT
Comment on attachment 607407 [details] [diff] [review]
patch

You should update removed-files.in too.
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-03-20 14:04:22 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> Comment on attachment 607407 [details] [diff] [review]
> patch
> 
> You should update removed-files.in too.

Why? This doesn't affect official builds where the files would be present and the files won't be there to be removed in self-made builds.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-03-20 14:34:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/47e510cf2416
Comment 5 Mounir Lamouri (:mounir) 2012-03-21 03:39:59 PDT
https://hg.mozilla.org/mozilla-central/rev/47e510cf2416

Note You need to log in before you can comment on or make changes to this bug.