The default bug view has changed. See this FAQ.

Make packager.pm missing file warnings fatal on Firefox

VERIFIED FIXED in Firefox 14

Status

()

Firefox
Build Config
P1
enhancement
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sid0, Assigned: sgautherie)

Tracking

Trunk
Firefox 14
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox12 wontfix, firefox13 wontfix)

Details

Attachments

(1 attachment)

To do this, we need to clean up browser/installer/package-manifest.in, then set MOZ_PKG_FATAL_WARNINGS = 1 before including packager.mk in browser/installer/Makefile.in.
(Assignee)

Updated

5 years ago
Depends on: 694353
(Assignee)

Updated

5 years ago
Depends on: 716397
(Assignee)

Updated

5 years ago
Depends on: 717491
(Assignee)

Comment 1

5 years ago
Created attachment 588077 [details] [diff] [review]
(Av1) Make packager.pm missing file warnings fatal on Firefox
[Checked in: Comment 16]

Let's prepare for when (new!) blockers are fixed.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #588077 - Flags: review?(khuey)
(Assignee)

Updated

5 years ago
Severity: normal → enhancement
Priority: -- → P1
Comment on attachment 588077 [details] [diff] [review]
(Av1) Make packager.pm missing file warnings fatal on Firefox
[Checked in: Comment 16]

Review of attachment 588077 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming this passes on try, r=me.

Thanks for doing this.
Attachment #588077 - Flags: review?(khuey) → review+
(Assignee)

Updated

5 years ago
Depends on: 652297
(Assignee)

Updated

5 years ago
Depends on: 718323
(Assignee)

Updated

5 years ago
Depends on: 718324
(Assignee)

Comment 3

5 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> Assuming this passes on try

Exactly what I had in progress ;-)
https://tbpl.mozilla.org/?tree=Try&rev=0f7ff1139bde
(Assignee)

Updated

5 years ago
Depends on: 712528
No longer depends on: 718323
(Assignee)

Updated

5 years ago
Depends on: 721535
(Assignee)

Updated

5 years ago
Depends on: 735810
(Assignee)

Comment 4

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> https://tbpl.mozilla.org/?tree=Try&rev=0f7ff1139bde

Succeeded again on Try:
https://tbpl.mozilla.org/?tree=Try&rev=acbbd1d961eb
(Assignee)

Updated

5 years ago
status-firefox12: --- → affected
status-firefox13: --- → affected
Flags: in-testsuite-
Keywords: checkin-needed
Whiteboard: [c-n: Av1 to m-i (if (expected) red, just back out)]
Target Milestone: --- → Firefox 14
Version: 12 Branch → Trunk
https://hg.mozilla.org/integration/mozilla-inbound/rev/a0fa92215a36
Keywords: checkin-needed
Whiteboard: [c-n: Av1 to m-i (if (expected) red, just back out)]
https://hg.mozilla.org/mozilla-central/rev/a0fa92215a36
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

5 years ago
https://tbpl.mozilla.org/?rev=7f540f758671

Win opt, Win pgo, Win debug, Win64 opt and Win64 pgo succeeded.

V.Fixed
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> Win opt, Win pgo, Win debug, Win64 opt and Win64 pgo succeeded.

All builds succeeded: that comment was related to bug 712528...
(Assignee)

Comment 9

5 years ago
Comment on attachment 588077 [details] [diff] [review]
(Av1) Make packager.pm missing file warnings fatal on Firefox
[Checked in: Comment 16]

[Approval Request Comment]
Regression caused by (bug #): (enhancement)
User impact if declined: None, but these warnings (usually) remain unnoticed.
Testing completed (on m-c, etc.): try, m-i, m-c.
Risk to taking this patch (and alternatives if risky): None, buildtime-only.
String changes made by this patch: None.
Attachment #588077 - Flags: approval-mozilla-beta?
Attachment #588077 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Depends on: 736739

Comment 10

5 years ago
See bug 736739 where this breaks packaging on official builds.

Comment 11

5 years ago
(In reply to Bob Clary [:bc:] from comment #10)
> See bug 736739 where this breaks packaging on official builds.

This was wrong as the bug is with --disable-installer builds. thanks to khuey for the identification.
Backed out in https://hg.mozilla.org/mozilla-central/rev/da5e8f6a44bd

We build RPM nightlies which build with --disable-updater, which was also broken by this.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Attachment #588077 - Attachment description: (Av1) Make packager.pm missing file warnings fatal on Firefox → (Av1) Make packager.pm missing file warnings fatal on Firefox [Backed out: comment 12]
(Assignee)

Updated

5 years ago
Depends on: 736770
(Assignee)

Comment 13

5 years ago
(In reply to Phil Ringnalda (:philor) from comment #12)
> We build RPM nightlies which build with --disable-updater, which was also
> broken by this.

I filed bug 736770, thanks to khuey who gave some missing details.
Status: REOPENED → ASSIGNED

Updated

5 years ago
Duplicate of this bug: 736544
(Assignee)

Comment 15

5 years ago
Ftr,
https://tbpl.mozilla.org/?tree=Try&rev=a01ca126fa5c
succeeded with --disable-crashreporter .
(package-manifest.in has an '#ifdef MOZ_CRASHREPORTER' ;-))
(Assignee)

Comment 16

5 years ago
Comment on attachment 588077 [details] [diff] [review]
(Av1) Make packager.pm missing file warnings fatal on Firefox
[Checked in: Comment 16]

https://hg.mozilla.org/mozilla-central/rev/cc552c8892cc
Attachment #588077 - Attachment description: (Av1) Make packager.pm missing file warnings fatal on Firefox [Backed out: comment 12] → (Av1) Make packager.pm missing file warnings fatal on Firefox [Checked in: Comment 16]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

5 years ago
https://tbpl.mozilla.org/?onlyunstarred=1&rev=cc552c8892cc

V.Fixed
Status: RESOLVED → VERIFIED
Depends on: 737301
Depends on: 737303
(Assignee)

Updated

5 years ago
Duplicate of this bug: 736544

Comment 19

5 years ago
With my mozconfig I get:

Warning: package error or possible missing or unnecessary file: bin/libnspr4.so (package-manifest, 33).
Warning: package error or possible missing or unnecessary file: bin/libplc4.so (package-manifest, 34).
Warning: package error or possible missing or unnecessary file: bin/libplds4.so (package-manifest, 35)
Warning: package error or possible missing or unnecessary file: bin/components/necko_wifi.xpt (package-manifest, 146).
Warning: package error or possible missing or unnecessary file: bin/components/nsSafebrowsingApplication.manifest (package-manifest, 311).
Warning: package error or possible missing or unnecessary file: bin/components/nsSafebrowsingApplication.js (package-manifest, 312).
Warning: package error or possible missing or unnecessary file: bin/components/nsURLClassifier.manifest (package-manifest, 313).
Warning: package error or possible missing or unnecessary file: bin/components/nsUrlClassifierHashCompleter.js (package-manifest, 314).
Warning: package error or possible missing or unnecessary file: bin/components/nsUrlClassifierListManager.js (package-manifest, 315).
Warning: package error or possible missing or unnecessary file: bin/components/nsUrlClassifierLib.js (package-manifest, 316).
Warning: package error or possible missing or unnecessary file: bin/components/url-classifier.xpt (package-manifest, 317).
Warning: package error or possible missing or unnecessary file: bin/libfreebl3.so (package-manifest, 394).
Warning: package error or possible missing or unnecessary file: bin/libnss3.so (package-manifest, 395).
Warning: package error or possible missing or unnecessary file: bin/libnssckbi.so (package-manifest, 396).
Warning: package error or possible missing or unnecessary file: bin/libnssdbm3.so (package-manifest, 397).
Warning: package error or possible missing or unnecessary file: bin/libnssutil3.so (package-manifest, 398).
Warning: package error or possible missing or unnecessary file: bin/libsmime3.so (package-manifest, 399).
Warning: package error or possible missing or unnecessary file: bin/libsoftokn3.so (package-manifest, 400).
Warning: package error or possible missing or unnecessary file: bin/libssl3.so (package-manifest, 401).

Wouldn't it have been wiser to make the missing file warnings fatal _after_ 
testing confirmed that nothing is broken accidentally?
(Assignee)

Comment 20

5 years ago
(In reply to Octoploid from comment #19)

> With my mozconfig I get:

Please don't spam this bug: file a blocking one for each option and related failures.

> Wouldn't it have been wiser to make the missing file warnings fatal _after_ 
> testing confirmed that nothing is broken accidentally?

Are you volunteering to do that testing?

Comment 21

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #20)
> (In reply to Octoploid from comment #19)
> 
> > With my mozconfig I get:
> 
> Please don't spam this bug: file a blocking one for each option and related
> failures.

Reporting build failures caused by your patch is not spam. Asking me to sort
through the mess you have created is naive.

> > Wouldn't it have been wiser to make the missing file warnings fatal _after_ 
> > testing confirmed that nothing is broken accidentally?
> 
> Are you volunteering to do that testing?

I just did that testing and reported my findings above.
Comment on attachment 588077 [details] [diff] [review]
(Av1) Make packager.pm missing file warnings fatal on Firefox
[Checked in: Comment 16]

[Triage Comment]
No user impact, therefore no reason to uplift this build behavior change.
Attachment #588077 - Flags: approval-mozilla-beta?
Attachment #588077 - Flags: approval-mozilla-beta-
Attachment #588077 - Flags: approval-mozilla-aurora?
Attachment #588077 - Flags: approval-mozilla-aurora-
(Assignee)

Updated

5 years ago
status-firefox12: affected → wontfix
status-firefox13: affected → wontfix
(Assignee)

Updated

5 years ago
No longer depends on: 737303
Depends on: 739132

Updated

5 years ago
Depends on: 737821

Comment 23

5 years ago
Backing out this bug fixes bug 737821.
Depends on: 743428
For a reason i dont understand this broke seamonkey 2.10 packaging, while it is targeted for  gecko 14/seamonkey 2.11.. investigating and filing followup bugs..
You need to log in before you can comment on or make changes to this bug.