change fonts used by Fizzilla Modern skin

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
enhancement
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: J Luh, Assigned: andreww)

Tracking

Trunk
Future
PowerPC
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I don't so much like the fonts used by the Fizzilla Modern skin. The font used
in the location bar and in prefs is so-so, and the font used in the status bar
is plain ugly. Are there other fonts that could be used?

Comment 1

17 years ago
Not completely sure if this is valid. Pinkerton?
yet another "modern font is ugly" bug.
Assignee: mpt → hewitt
Status: UNCONFIRMED → NEW
Component: User Interface: Design Feedback → Themes
Ever confirmed: true

Comment 3

17 years ago
At this point, if you don't like the way fonts look under the Modern theme,
don't blame the theme.  The CSS specifies the correct fonts, and it's up to the
style system to get the right fonts at the right size from the OS.
Assignee: hewitt → pierre
Component: Themes → Style System
QA Contact: zach → ian
(Reporter)

Comment 4

17 years ago
Re: the previous comment: What are the "correct" fonts? Could it be that the
fonts specified by the skin are not available in Mac OS X, or look bad in Mac OS X?

Comment 5

17 years ago
My guess is that nsDeviceContextMac::GetSystemAttribute() needs to be revisited 
for OS-X.

Otherwise, the fonts are specified in macprefs.js.  Look for these 4 lines...
   pref("font.name.serif.x-unicode", "Times");
   pref("font.name.sans-serif.x-unicode", "Helvetica");
   pref("font.name.serif.x-western", "Times");
   pref("font.name.sans-serif.x-western", "Helvetica");
Maybe we need a different prefs file for OS-X, or different font names that would 
work on OS-9 and OS-X.

Mike, could you look into it?  If you don't find anything in the Mac-specific 
code (gfx or prefs), reassign to peterl or attinasi.
Assignee: pierre → pinkerton
spreading the pain.
Assignee: pinkerton → sdagley

Comment 7

17 years ago
Marking dependency on bug 61883 "Smarter default prefs for the 5 basic CSS fonts" 
because the format of these prefs will soon change, supporting several font names 
to be specified.
Depends on: 61883

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 8

17 years ago
Looks like we're using Lucida Grande for the Modern fonts, for the location bar,
prefs, status bar, buttons, everything in fact? If so, I'm not sure what the
issue is; Lucida Grande is the font to use for UI, in my humble opinion.

Perhaps what would improve things would be bug 74245 -- using Quartz to render
fonts would make Mozilla's text look nicer, more like the menu bar text, title
bar, etc.

Comment 9

17 years ago
Oop, looking back on the timestamps, it's quite possible that since the reporter
found the bug, a whole new Modern theme had landed :-)

mozilla.org@pidgin.org, how do you like the current Modern fonts?
(Reporter)

Comment 10

17 years ago
Created attachment 38917 [details]
screen shot
(Reporter)

Comment 11

17 years ago
I've attached a screen shot showing what it looks like on my computer. 
Still pretty ugly, particularly the asymmetrical w's. 

I don't know if using Quartz would fix it, but is Quartz font rendering likely to 
show up soon? If not, I suggest using a different font that looks better 
when bitmapped like this.

Updated

17 years ago
Blocks: 88358
(Reporter)

Comment 12

17 years ago
It looks like the font being used is Lucida Grande, as Terence Tan noted
2001-06-18. However, since Lucida Grande is meant to be used with Quartz font
rendering, it doesn't look so attractive. How about changing the font to Geneva
or another font that looks better with the old Mac rendering?

Comment 13

17 years ago
Terence Tan has the right idea. Lucida Grande is the right font to use for OS X
UI things. Using the Quartz 2D api will improve the appearance of that font.

Therefore, this bug should not depend on 61883, but rather 74245 as Terence
suggests.

Comment 14

16 years ago
re-assigning to modern owner
Assignee: sdagley → hewitt
(Reporter)

Comment 15

16 years ago
In my opinion, Geneva looks slightly better than Lucida Grande as the font.
Verdana looks even better, though I don't think it is preinstalled by the system.

If you don't intend to change the font, however, feel free to mark this bug invalid.

Comment 16

16 years ago
Mass reassigning some of my theme bugs to Shuehan.
Assignee: hewitt → shliang

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 17

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

16 years ago
Target Milestone: mozilla1.0.1 → Future

Comment 18

16 years ago
-> andrew
Assignee: shliang → andreww
Status: ASSIGNED → NEW
adjusting dependency, -> Themes
Component: Style System → Themes
Depends on: 74245
No longer depends on: 61883

Comment 20

16 years ago
*** Bug 134506 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

16 years ago
This is no longer applicable since Mozilla now uses system anti-aliasing on Mac
OS X (bug 149427).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.