B2G RIL: typo in RIL iccIO

RESOLVED FIXED in mozilla14

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: allstars, Assigned: allstars)

Tracking

Trunk
mozilla14
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This bug is a regression from Bug 735581.
the argument for EF path should be pathid, instead of path.
(Assignee)

Updated

5 years ago
Summary: typo in RIL iccIO → B2G RIL: typo in RIL iccIO
(Assignee)

Updated

5 years ago
Assignee: nobody → yhuang
(Assignee)

Comment 1

5 years ago
Find out it's the problem of Bug 720638.
Android emulator doesn't check EF_Path argument so I get always get the number.
This also explains why I cannot get phone number on my device.
reopen Bug 720638.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720638
Please don't reopen bugs for follow-up fixes. Follow-up bugs are the correct way to deal with those.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

5 years ago
Created attachment 607843 [details] [diff] [review]
fix typo in iccIO

Fix typo in iccIO.
It seems Ril didn't check EF Path at all so I didn't spot this typo in the first place(Bug 728638), sorry for my mistake.
Attachment #607843 - Flags: review?(philipp)
Attachment #607843 - Flags: review?(philipp) → review+
(Assignee)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: checkin-needed
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: checkin-needed
Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: FIXED → ---
https://hg.mozilla.org/integration/mozilla-inbound/rev/fcfebfd76082
Status: REOPENED → NEW
https://hg.mozilla.org/mozilla-central/rev/fcfebfd76082
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
You need to log in before you can comment on or make changes to this bug.