Last Comment Bug 737582 - Remove redundant "gingerbread" and "honeycomb" themes and unused theme files
: Remove redundant "gingerbread" and "honeycomb" themes and unused theme files
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 14
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks: 734797
  Show dependency treegraph
 
Reported: 2012-03-20 12:29 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-03-24 07:53 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (53.88 KB, patch)
2012-03-20 12:29 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2012-03-20 12:29:39 PDT
Created attachment 607659 [details] [diff] [review]
patch

We have three themes, but there are no longer any meaningful differences between them; browser.css is literally identical in all three themes, while content.css differs in a few small ways in the "gingerbread" theme (and is identical for froyo and honeycomb).

The "gingerbread" theme is used on Android 2.3 and 4.0+ which account for the majority of our development devices, so the other themes are not really tested.  This duplication seems likely to lead to uncaught bugs in the less-used themes.

This patch simply removes the gingerbread and honeycomb theme directories.  I kept the "defines.inc" and "content.css" from the gingerbread theme because I expect they are better-tested than the froyo versions, but I merged in some changes that had been made to the froyo versions only.

This also removes some unused image files.

This patch shrinks the APK package by about 350KB.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-20 14:22:59 PDT
Comment on attachment 607659 [details] [diff] [review]
patch

Nice cleanup!
Comment 3 Mounir Lamouri (:mounir) 2012-03-21 03:39:11 PDT
https://hg.mozilla.org/mozilla-central/rev/1262bdd35f9d
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-24 07:53:46 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/68578d82198b

Note You need to log in before you can comment on or make changes to this bug.