Last Comment Bug 737692 - Menulists and textboxes need better styling in add-on options
: Menulists and textboxes need better styling in add-on options
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 14
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on: 696533
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 16:40 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-06-01 07:31 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
-
13+


Attachments
patch (2.24 KB, patch)
2012-03-20 16:40 PDT, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review
screenshot (81.98 KB, image/png)
2012-03-20 23:05 PDT, Matt Brubeck (:mbrubeck)
no flags Details

Description Matt Brubeck (:mbrubeck) 2012-03-20 16:40:16 PDT
Created attachment 607772 [details] [diff] [review]
patch

This makes XUL menulists and textboxes larger (more touch-friendly) and prettier on about:addons.  The styles are basically copied from the HTML content theme.

It also disables spinbuttons on <textbox type="number"> widgets.  I'll file a follow-up bug to bring back the spinbuttons with a touch-friendly theme like in XUL Fennec.

Nominating for blocking because many add-on options are not really usable without this change.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-20 19:17:03 PDT
Comment on attachment 607772 [details] [diff] [review]
patch

Looks good. Get an OK from Patryk too, from a screenshot?

Also, for number textboxes, do we use the number-centric soft-keyboard? I know we can use a attribute to get the VKB to show a keyboard with a numpad on it.
Comment 2 Matt Brubeck (:mbrubeck) 2012-03-20 23:05:29 PDT
Created attachment 607866 [details]
screenshot

How's this look, Patryk?  For comparison, current builds look basically like attachment 601991 [details].  If you'd like to make changes at this stage, we can polish things up here, or open a followup bug if you want to provide whole new mockups or assets.

(In reply to Mark Finkle (:mfinkle) from comment #1)
> Also, for number textboxes, do we use the number-centric soft-keyboard?

No; I'll submit a follow-up bug for that.
Comment 3 Matt Brubeck (:mbrubeck) 2012-03-20 23:28:43 PDT
(In reply to Matt Brubeck (:mbrubeck) from comment #2)
> > Also, for number textboxes, do we use the number-centric soft-keyboard?
> 
> No; I'll submit a follow-up bug for that.

Filed bug 638143.
Comment 4 Matt Brubeck (:mbrubeck) 2012-03-22 13:04:37 PDT
Landed with some layout tweaks requested by Patryk on IRC:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d34c8cafbdb1
Comment 5 Marco Bonardo [::mak] 2012-03-23 05:46:38 PDT
https://hg.mozilla.org/mozilla-central/rev/d34c8cafbdb1
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-24 07:49:09 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/47135409a694
Comment 7 Adrian Tamas (:AdrianT) 2012-06-01 07:31:09 PDT
Tested using the Zippity Testharness2.0 from http://people.mozilla.com/~mfinkle/addons/. 
Verified fix on:
Nightly 2012-06-01/ Aurora 2012-06-01
Device: HTC Desire 
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.