Last Comment Bug 737867 - Apply ViewHolder pattern on AwesomeBar listviews
: Apply ViewHolder pattern on AwesomeBar listviews
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 14
Assigned To: Lucas Rocha (:lucasr)
:
:
Mentors:
Depends on: 740094
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 07:54 PDT by Lucas Rocha (:lucasr)
Modified: 2012-04-04 10:16 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs (16.13 KB, patch)
2012-03-21 08:25 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
margaret.leibovic: feedback+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
(2/3) Apply ViewHolder pattern on AwesomeBar's History tab (4.64 KB, patch)
2012-03-21 08:25 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
(3/3) Share same LayoutInflater instance in AwesomeBarTabs (6.93 KB, patch)
2012-03-21 08:25 PDT, Lucas Rocha (:lucasr)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Lucas Rocha (:lucasr) 2012-03-21 07:54:44 PDT
This should give us a 4-5fps increase when scrolling awesomebar views due to the reduced number of findViewById() calls in each adapter.
Comment 1 Lucas Rocha (:lucasr) 2012-03-21 08:25:14 PDT
Created attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs
Comment 2 Lucas Rocha (:lucasr) 2012-03-21 08:25:22 PDT
Created attachment 607969 [details] [diff] [review]
(2/3) Apply ViewHolder pattern on AwesomeBar's History tab
Comment 3 Lucas Rocha (:lucasr) 2012-03-21 08:25:31 PDT
Created attachment 607970 [details] [diff] [review]
(3/3) Share same LayoutInflater instance in AwesomeBarTabs
Comment 4 Lucas Rocha (:lucasr) 2012-03-21 08:50:36 PDT
Comment on attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs

I'd like to get feedback from Margaret as she did a lot of work on the bookmarks adapter.
Comment 5 :Margaret Leibovic 2012-03-21 22:27:32 PDT
Comment on attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs

This looks good to me. I was reading up on the ViewHolder pattern, and you seem to be following what I've seen.

Although I wrote this code, I'm wondering why we don't have an @Override tag on getItemViewType, since the things I've read talked about overriding getItemViewType if you're using multiple list item types.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-22 10:33:10 PDT
Comment on attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs

Looks OK to me too. I had to "read up" on the ViewHolder pattern too :)
Comment 9 Lucas Rocha (:lucasr) 2012-04-03 03:03:53 PDT
Comment on attachment 607970 [details] [diff] [review]
(3/3) Share same LayoutInflater instance in AwesomeBarTabs

Mobile only. Release blocker.
Comment 10 Lucas Rocha (:lucasr) 2012-04-03 03:03:59 PDT
Comment on attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs

Mobile only. Release blocker.
Comment 11 Lucas Rocha (:lucasr) 2012-04-03 03:04:05 PDT
Comment on attachment 607969 [details] [diff] [review]
(2/3) Apply ViewHolder pattern on AwesomeBar's History tab

Mobile only. Release blocker.
Comment 12 Alex Keybl [:akeybl] 2012-04-03 15:09:40 PDT
Comment on attachment 607968 [details] [diff] [review]
(1/3) Apply ViewHolder pattern in AwesomeBar's All/Bookmarks tabs

[Triage Comment]
Mobile only & blocking Fennec 1.0. Approved for Aurora 13.

Note You need to log in before you can comment on or make changes to this bug.