Last Comment Bug 740094 - Bookmarks folder icons don't appear anymore
: Bookmarks folder icons don't appear anymore
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 14
Assigned To: :Margaret Leibovic
:
:
Mentors:
: 740299 (view as bug list)
Depends on:
Blocks: 737867
  Show dependency treegraph
 
Reported: 2012-03-28 12:19 PDT by :Margaret Leibovic
Modified: 2012-04-04 10:12 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
patch (1.26 KB, patch)
2012-03-28 12:19 PDT, :Margaret Leibovic
lucasr.at.mozilla: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Margaret Leibovic 2012-03-28 12:19:51 PDT
Created attachment 610240 [details] [diff] [review]
patch

This is a regression caused by bug 737867. We shouldn't call updateFavicon for folder item types, since the favicon is just always the folder icon.

I tested this patch and it fixes the problem.
Comment 2 Aaron Train [:aaronmt] 2012-03-29 07:05:11 PDT
*** Bug 740299 has been marked as a duplicate of this bug. ***
Comment 3 Marco Bonardo [::mak] 2012-03-29 08:53:52 PDT
https://hg.mozilla.org/mozilla-central/rev/b2c747fcacea
Comment 4 Paul Feher 2012-04-02 06:27:27 PDT
Verified/fixed on:
Nightly Fennec 14.0a1 (2012-04-01)
Device: Samsung Nexus S
OS: Android 2.3.6
Comment 5 :Margaret Leibovic 2012-04-02 16:46:59 PDT
Comment on attachment 610240 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 737867
User impact if declined: bookmark folder icons don't appear
Testing completed (on m-c, etc.): Landed on m-c 3/29
Risk to taking this patch (and alternatives if risky): low risk, mobile only
String changes made by this patch: None
Comment 6 Alex Keybl [:akeybl] 2012-04-03 15:11:25 PDT
Comment on attachment 610240 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 13.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-04 10:12:05 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/b88204f7e018

Note You need to log in before you can comment on or make changes to this bug.