Closed Bug 738096 Opened 8 years ago Closed 8 years ago

Rename a subfolder will change all the message filters to go this folder

Categories

(Thunderbird :: Mail Window Front End, defect, major)

11 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 735940

People

(Reporter: farid, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I changed one of my subfolders name



Actual results:

After the change all my emails started going to that folder.
I checked my filters to find that all have been changed to point to this subfolder.




Expected results:

my subfolder name should change without affecting any filters.
Severity: normal → major
Was any filter originally set move/copy messages to this folder that you renamed?
(In reply to Farid Shouekani from comment #0)
I did the following:
1. Created filter to move messages from IMAP folder to local folder.
2. Renamed the destination folder.
3. Filter destination folder name was updated to the new name.

So, there is no issue here.

User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120312 Thunderbird/11.0
Application Build ID: 20120312195326
Hashem, see if not other filter were changed to the same folder.

My aim is if this isn't the same as bug 735940.
(In reply to :aceman from comment #3)
> Hashem, see if not other filter were changed to the same folder.
> 
> My aim is if this isn't the same as bug 735940.

Point 2 (renaming of folder) is done through the folder pane. I tried it now and 2 filters were updated to the newly renamed folder. This is normal behavior IMO.
I tested the bug again by creating a new folder then renaming it, and all my filters changed to this folder.  

So, there is no need to have any filter pointing to the folder for this to happen.

When I changed the folder name, I had the message filter dialog box open.  (this may be a clue to the issue.)
I did read Bug 735940, this is different way to get to the same bug "I think".

So, they are related in the results but different in the origin.
Ok, if you mind. So let's wait for fixing of bug 735940 and then we will see if this one here will still exist.

(In reply to Farid Shouekani from comment #5)
> So, there is no need to have any filter pointing to the folder for this to
> happen.
You do not need to point directly to the folder being renamed. But you must have at least one filter pointing to the folder OR any of its subfolders.
Depends on: 735940
NP, I think you should try to recreate it so it may help you in the other bug.
possible having the message filter dialog open is the trick.
Farid could you test a nightly build and tell us if the issue is fixed ?
But give it a few hours or a day, there is probably not yet a nightly build that already has patch from bug 735940.
Hi,
I got the update 11.01 and tested the build on windows 7 and xp, both worked ok.   I changed the folder name and left the message filler box open and crated new filters they did not go up on the message filter box I had to close it and reopen it to get the new filter.  This way the list of the old filter did not get corrupted.  Renaming folders not affecting any old filters.

I guess this can be marked as squished bug.

Regards,
Great thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
No longer depends on: 735940
Resolution: --- → DUPLICATE
Duplicate of bug: 735940
You need to log in before you can comment on or make changes to this bug.