Last Comment Bug 738334 - Intermittent dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output after Assertion failure: !IsNull() (Cannot compute with a null value) in TimeStamp.h and ASSERTION: nsScriptCacheCleaner not thread-safe
: Intermittent dom/workers/test/test_xhr_timeout.html | application timed out a...
Status: RESOLVED FIXED
[qa-]
: assertion, intermittent-failure
Product: Core
Classification: Components
Component: DOM: Workers (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla14
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 438871 739037
  Show dependency treegraph
 
Reported: 2012-03-22 10:24 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
affected
affected
13+
fixed


Attachments
Patch (1.09 KB, patch)
2012-03-23 10:37 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
bent.mozilla: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta-
lukasblakk+bugs: approval‑mozilla‑esr10+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor) 2012-03-22 10:24:58 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=10263952&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-3/5 on 2012-03-21 19:51:37 PDT for push 2943b3d6edfe

11060 INFO TEST-START | /tests/dom/workers/test/test_xhr_timeout.html
++DOMWINDOW == 3452 (05047380) [serial = 7879] [outer = 057957A0]
--DOMWINDOW == 3451 (24FF9F98) [serial = 7870] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/workers/test/test_terminate.html]
--DOMWINDOW == 3450 (14126F68) [serial = 7871] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/workers/test/test_threadErrors.html]
11061 INFO TEST-PASS | /tests/dom/workers/test/test_xhr_timeout.html | no time out scheduled, load fires normally, timeout scheduled at 0 - "load" should equal "load"
Assertion failure: !IsNull() (Cannot compute with a null value), at e:\builds\moz2_slave\m-in-w32-dbg\build\obj-firefox\dist\include\mozilla/TimeStamp.h:223
nsStringStats
 => mAllocCount:        2851842
 => mReallocCount:       253490
 => mFreeCount:         2693190  --  LEAKED 158652 !!!
 => mShareCount:        6660501
 => mAdoptCount:         352655
 => mAdoptFreeCount:     352646  --  LEAKED 9 !!!
###!!! ASSERTION: nsScriptCacheCleaner not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file e:/builds/moz2_slave/m-in-w32-dbg/build/content/base/src/nsFrameMessageManager.cpp, line 906
TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
args: ['C:\\talos-slave\\test\\build\\bin\\screenshot.exe', 'c:\\docume~1\\cltbld\\locals~1\\temp\\mozilla-test-fail_suvj7f']
(screenshot)
command timed out: 1200 seconds without output, attempting to kill
Comment 2 Serge Gautherie (:sgautherie) 2012-03-22 16:43:40 PDT
(In reply to Phil Ringnalda (:philor) from comment #1)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=10270841&tree=Mozilla-
> Inbound

Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-3/5 on 2012-03-22 00:44:17 PDT for push dd6e82e5edac

*****

SeaMonkey has it a little differently, like:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332050249.1332054389.23291.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitests-3/5 on 2012/03/17 22:57:29
s: cb-seamonkey-win32-03

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332447525.1332451645.23137.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitests-3/5 on 2012/03/22 13:18:45
s: cb-seamonkey-win32-01
{
9665 INFO TEST-START | /tests/dom/workers/test/test_xhr_timeout.html

###!!! ASSERTION: Must have a proxy here!: 'mProxy', file e:/builds/slave/comm-cen-trunk-w32-dbg/build/mozilla/dom/workers/XMLHttpRequestPrivate.cpp, line 2166
...

9666 INFO TEST-PASS | /tests/dom/workers/test/test_xhr_timeout.html | no time out scheduled, load fires normally, timeout scheduled at 0 - "load" should equal "load"

###!!! ASSERTION: You can't dereference a NULL nsRefPtr with operator->().: 'mRawPtr != 0', file e:\builds\slave\comm-cen-trunk-w32-dbg\build\objdir\mozilla\dist\include\nsAutoPtr.h, line 1056
...

###!!! ASSERTION: nsScriptCacheCleaner not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file e:/builds/slave/comm-cen-trunk-w32-dbg/build/mozilla/content/base/src/nsFrameMessageManager.cpp, line 906
TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
}
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-23 10:32:02 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> (In reply to Phil Ringnalda (:philor) from comment #1)
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=10270841&tree=Mozilla-
> > Inbound
> 
> Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-3/5 on 2012-03-22
> 00:44:17 PDT for push dd6e82e5edac
> 
> *****
> 
> SeaMonkey has it a little differently, like:
> 
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332050249.1332054389.
> 23291.gz&fulltext=1
> WINNT 5.2 comm-central-trunk debug test mochitests-3/5 on 2012/03/17 22:57:29
> s: cb-seamonkey-win32-03
> 
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332447525.1332451645.
> 23137.gz&fulltext=1
> WINNT 5.2 comm-central-trunk debug test mochitests-3/5 on 2012/03/22 13:18:45
> s: cb-seamonkey-win32-01
> {
> 9665 INFO TEST-START | /tests/dom/workers/test/test_xhr_timeout.html
> 
> ###!!! ASSERTION: Must have a proxy here!: 'mProxy', file
> e:/builds/slave/comm-cen-trunk-w32-dbg/build/mozilla/dom/workers/
> XMLHttpRequestPrivate.cpp, line 2166
> ...
> 
> 9666 INFO TEST-PASS | /tests/dom/workers/test/test_xhr_timeout.html | no
> time out scheduled, load fires normally, timeout scheduled at 0 - "load"
> should equal "load"
> 
> ###!!! ASSERTION: You can't dereference a NULL nsRefPtr with operator->().:
> 'mRawPtr != 0', file
> e:\builds\slave\comm-cen-trunk-w32-
> dbg\build\objdir\mozilla\dist\include\nsAutoPtr.h, line 1056
> ...
> 
> ###!!! ASSERTION: nsScriptCacheCleaner not thread-safe:
> '_mOwningThread.GetThread() == PR_GetCurrentThread()', file
> e:/builds/slave/comm-cen-trunk-w32-dbg/build/mozilla/content/base/src/
> nsFrameMessageManager.cpp, line 906
> TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html |
> application timed out after 330 seconds with no output
> }

That's something else.
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-23 10:37:25 PDT
Created attachment 608760 [details] [diff] [review]
Patch
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-23 10:47:56 PDT
http://hg.mozilla.org/mozilla-central/rev/d41503780635
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-23 11:15:58 PDT
Comment on attachment 608760 [details] [diff] [review]
Patch

This is a pretty rare race condition but the results are quite bad.  We'd like to take this wherever drivers will let us.

[Approval Request Comment]
Regression caused by (bug #): Worker rewrite (several months ago)
User impact if declined: a rare race condition that results in bad things.
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): risk is low
String changes made by this patch: N/A
Comment 7 Serge Gautherie (:sgautherie) 2012-03-23 17:11:55 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> > SeaMonkey has it a little differently, like:
> 
> That's something else.

Should I file a separate bug? Any idea about whet the cause could be?
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-03-23 17:17:55 PDT
Yes.  Not off the top of my head, but I'll try to find some time to look into it.
Comment 9 Serge Gautherie (:sgautherie) 2012-03-25 03:18:38 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> > > SeaMonkey has it a little differently, like:
> > 
> > That's something else.
> 
> Should I file a separate bug? Any idea about whet the cause could be?

I filed bug 739037.
Comment 10 Alex Keybl [:akeybl] 2012-03-26 14:01:44 PDT
Comment on attachment 608760 [details] [diff] [review]
Patch

[Triage Comment]
Since the associated risk is low and this gets rid of some orange, approved for Aurora 13. Since it's rare and requires a change in code, we'll delay the landing and skip Beta 12.

As for the ESR - is this orange common enough to take for sake of dev sanity? If not, it doesn't seem as if it meets the criteria for ESR from the user perspective.
Comment 11 Treeherder Robot 2012-04-03 09:30:57 PDT
sgautherie
https://tbpl.mozilla.org/php/getParsedLog.php?id=10601670&tree=Firefox
Rev3 WINNT 5.1 mozilla-central debug test mochitests-3/5 on 2012-04-03 08:25:37

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
Comment 12 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-03 11:30:37 PDT
[Triage Comment]
Tracking for ESR-next, so we get some bake time on Aurora.
Comment 13 Treeherder Robot 2012-04-11 23:03:00 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=10829345&tree=Services-Central
Rev3 WINNT 5.1 services-central debug test mochitests-3/5 on 2012-04-11 18:07:22

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
Comment 14 Lukas Blakk [:lsblakk] use ?needinfo 2012-04-25 13:27:21 PDT
Comment on attachment 608760 [details] [diff] [review]
Patch

[Triage Comment]
Time has come, please land to ESR (Firefox 13)
Comment 15 Treeherder Robot 2012-05-01 12:32:40 PDT
bugs%pettay.fi
https://tbpl.mozilla.org/php/getParsedLog.php?id=11364547&tree=Try
Rev3 Fedora 12 try debug test mochitests-1/5 on 2012-05-01 12:24:21
slave: talos-r3-fed-054

TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_XHR_timeout.html | Exited with code 1 during test run
PROCESS-CRASH | /tests/content/base/test/test_XHR_timeout.html | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!
Comment 16 Treeherder Robot 2012-05-05 07:54:04 PDT
ryanvm%gmail.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=11498040&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-3/5 on 2012-05-05 06:55:26
slave: talos-r3-xp-052

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
Comment 17 Treeherder Robot 2012-05-28 12:51:45 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12137522&tree=Mozilla-Beta
Rev4 MacOSX Snow Leopard 10.6 mozilla-beta debug test mochitests-3/5 on 2012-05-28 11:40:34
slave: talos-r4-snow-074

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | Exited with code 1 during test run
PROCESS-CRASH | /tests/dom/workers/test/test_xhr_timeout.html | application crashed (minidump found)
Thread 8 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!
Comment 18 Johnny Stenback (:jst, jst@mozilla.com) 2012-05-30 16:11:48 PDT
https://hg.mozilla.org/releases/mozilla-esr10/rev/d81a789ad0cd
Comment 19 Treeherder Robot 2012-06-05 08:00:01 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=12380515&tree=Mozilla-Release
Rev3 WINNT 5.1 mozilla-release debug test mochitests-3/5 on 2012-06-05 04:14:50
slave: talos-r3-xp-022

TEST-UNEXPECTED-FAIL | /tests/dom/workers/test/test_xhr_timeout.html | application timed out after 330 seconds with no output
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-07-12 15:45:52 PDT
I don't think this is anything QA needs to explicitly verify, flagging [qa-]. Please correct me if I am wrong.

Note You need to log in before you can comment on or make changes to this bug.