Upgrade Mozilla to NSS 3.13.5 final

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: kaie, Assigned: kaie)

Tracking

10 Branch
mozilla15
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14+ verified, firefox-esr1014+ verified)

Details

Attachments

(2 attachments)

Assignee

Description

7 years ago
It's not released yet, but eventually we will have to upgrade Mozilla to NSS 3.13.4 final.

Here is one motiviation why we might want to do so for Firefox 14, prior to April 24:

- Firefox 14 will disable MD5 signatures by default

- our current user feedback on affected SSL sites is not helpful

- bug 738454 (target NSS 3.13.4) implements a better error code for 
  "disabled by policy"

Once this bug is resolved (Mozilla updated to 3.13.4) we'll also need to land 738457 into Mozilla application (PSM), for the user feedback to become effective.
Assignee

Comment 1

7 years ago
As there will probably be an additional update 3.13.4, which will not yet cover the md5 related work, I'm moving this tracking bug to 3.13.5
Summary: Upgrade Mozilla to NSS 3.13.4 final → Upgrade Mozilla to NSS 3.13.5 final
Assignee

Updated

7 years ago
Assignee

Comment 2

7 years ago
Attachment #617730 - Flags: review?(wtc)

Comment 3

7 years ago
Comment on attachment 617730 [details]
upgrade action (placeholder)

r=wtc.
Attachment #617730 - Flags: review?(wtc) → review+
Assignee

Comment 4

7 years ago
I'll land the NSS_3_13_5_BETA1 tag.
We must keep this open until we land the final release.
Whiteboard: [keep open after merge]
Is this still necessary for FF14 if we're no longer disabling MD5 signatures for that release?
Assignee

Comment 8

7 years ago
(In reply to Alex Keybl [:akeybl] from comment #7)
> Is this still necessary for FF14 if we're no longer disabling MD5 signatures
> for that release?

If you backout 650355 for FF14: no, not necessary for MD5.

But what about bug 745548 ?
Assignee

Updated

7 years ago
Depends on: 745548
Assignee

Comment 9

7 years ago
Can I please get a r+ (in a comment) for landing beta2 into mozilla-central?
Thanks.
r+ on landing beta2 in mozilla-central.

Comment 11

7 years ago
Kai: please push NSS_3_13_5_BETA2 to mozilla-central.
Assignee

Comment 13

7 years ago
(only difference between beta1 and beta2 was fix for bug 745548.)
Assignee

Comment 15

7 years ago
I've checked in the final NSS 3.13.5.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5eb0d9e63d5a

The only functional change since the beta version was:
- a one letter typo in an error string
- final version number 

However, some of the files which belong to NSS, which are copied into mozilla-central, have been modified in mozilla-central to use the MPL2. My change reverts these few license headers to the old tri-license, which is what most of NSS still uses (on this particular stable branch). IMHO that shouldn't be a problem, the license headers will be changed to MPL2 when Mozilla picks up a more recent version of NSS where Gerv has applied the MPL2 headers everywhere.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [keep open after merge]
Assignee

Comment 16

7 years ago
Sorry, reopening, must wait until inbound has been merged to central.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Kai: that's not a problem, but can you tell me which files those are, so I can check if my script is faulty?

Thanks,

Gerv
Assignee

Comment 18

7 years ago
(In reply to Gervase Markham [:gerv] from comment #17)
> Kai: that's not a problem, but can you tell me which files those are, so I
> can check if my script is faulty?

yes, see the commit in coment 15
Assignee

Comment 19

7 years ago
(In reply to Kai Engert (:kaie) from comment #18)
> (In reply to Gervase Markham [:gerv] from comment #17)
> > Kai: that's not a problem, but can you tell me which files those are, so I
> > can check if my script is faulty?
> 
> yes, see the commit in coment 15


Note that your script might have worked fine on NSS trunk.

The cause for this (temporary) reversion (on mozilla-central) is that we still do some work on a separate stable NSS branch.
https://hg.mozilla.org/mozilla-central/rev/5eb0d9e63d5a
Assignee: nobody → kaie
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Assignee

Comment 21

7 years ago
Proposing for ESR 10.0.6, in order to pick up bug 745548.

ESR10 branch already uses NSS 3.13.4.
An upgrade to NSS 3.13.5 is a very small change.
Assignee

Updated

7 years ago
Attachment #617730 - Flags: approval-mozilla-esr10?
Assignee

Comment 22

7 years ago
Proposing for Firefox 14/Beta, in order to pick up bug 745548.

Beta already uses NSS 3.13.4.
An upgrade to NSS 3.13.5 is a very small change.
Assignee

Updated

7 years ago
Attachment #617730 - Flags: approval-mozilla-esr10?
Assignee

Comment 23

7 years ago
Attachment #631489 - Flags: approval-mozilla-esr10?
Attachment #631489 - Flags: approval-mozilla-beta?
Comment on attachment 631489 [details] [diff] [review]
upgrade action to 3.13.5 final (placeholder)

[Triage Comment]
Approved for Beta and ESR, given bug 745548.
Attachment #631489 - Flags: approval-mozilla-esr10?
Attachment #631489 - Flags: approval-mozilla-esr10+
Attachment #631489 - Flags: approval-mozilla-beta?
Attachment #631489 - Flags: approval-mozilla-beta+
Assignee

Comment 26

7 years ago
(In reply to Kai Engert (:kaie) from comment #25)
> https://hg.mozilla.org/releases/mozilla-beta/rev/853ac25ddd18

This commit accidentally landed into a release branch.
I've backed it out from the release branch:
https://hg.mozilla.org/releases/mozilla-beta/rev/87828c8651c6


I hope the following is the correct landing on mozilla-beta "default" branch:
https://hg.mozilla.org/releases/mozilla-beta/rev/cc5c3ee63206
You need to log in before you can comment on or make changes to this bug.