Last Comment Bug 738527 - Syntax error breaks removing closed tabs
: Syntax error breaks removing closed tabs
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: Firefox 14
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 738768 (view as bug list)
Depends on:
Blocks: 697309
  Show dependency treegraph
 
Reported: 2012-03-22 18:57 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-04-04 10:22 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (1.85 KB, patch)
2012-03-22 18:57 PDT, Mark Finkle (:mfinkle) (use needinfo?)
bnicholson: review+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-03-22 18:57:52 PDT
Created attachment 608562 [details] [diff] [review]
patch

The code throws an exception and the tab is not completely destroyed or removed from the BrowserApp.tabs array. This patch fixes it.
Comment 1 Brian Nicholson (:bnicholson) 2012-03-23 13:30:31 PDT
*** Bug 738768 has been marked as a duplicate of this bug. ***
Comment 2 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-03-23 13:53:58 PDT
*rages against the insanity of using javascript for critical components*
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-23 13:57:06 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/563021526711
Comment 4 Ed Morley [:emorley] 2012-03-24 13:56:46 PDT
Please can you set the target milestone + assignee when landing on inbound, along the lines of http://blog.bonardo.net/2012/03/23/how-you-can-help-mozilla-inbound-sheriffs-when-pushing :-)

https://hg.mozilla.org/mozilla-central/rev/563021526711
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-04-04 10:22:16 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/c71d1eb305bc

Note You need to log in before you can comment on or make changes to this bug.