Closed Bug 738768 Opened 10 years ago Closed 10 years ago

"this.browser.controllers.contentWindow is undefined" when closing tab

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 738527

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

Attachments

(1 file)

Every time I close a tab, I see this error:

03-23 11:16:20.432  9694  9704 E GeckoConsole: [JavaScript Error: "this.browser.controllers.contentWindow is undefined" {file: "chrome://browser/content/browser.js"

This looks like a typo from bug 729373, and it means that nothing is getting called in tab.destroy(). I imagine this is creating a number of problems related to closing tabs/quitting.
Attached patch patchSplinter Review
Attachment #608841 - Flags: review?(mark.finkle)
Duplicate of this bug: 736470
Oops, looks like this is already filed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738527
blocking-fennec1.0: ? → ---
Attachment #608841 - Flags: review?(mark.finkle)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.