Note: There are a few cases of duplicates in user autocompletion which are being worked on.

cleanup mozglue for gonk

RESOLVED FIXED in mozilla14

Status

()

Core
mozglue
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gal, Assigned: mwu)

Tracking

Trunk
mozilla14
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #738559 +++
(Reporter)

Comment 1

5 years ago
Comment on attachment 608621 [details] [diff] [review] [diff] [review]
patch

Review of attachment 608621 [details] [diff] [review] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +7274,3 @@
>      fi
> +    WRAP_LDFLAGS="${WRAP_LDFLAGS} -Wl,--wrap=getaddrinfo,--wrap=freeaddrinfo,--wrap=gai_strerror"
> +    WRAP_LDFLAGS="${WRAP_LDFLAGS} -Wl,--wrap=fork,--wrap=pthread_atfork"

Do you really want to also wrap getaddrinfo, etc.?

::: mozglue/build/Makefile.in
@@ +96,5 @@
> +# To properly wrap jemalloc's pthread_atfork call.
> +EXTRA_DSO_LDOPTS += -Wl,--wrap=pthread_atfork
> +SHARED_LIBRARY_LIBS += $(call EXPAND_LIBNAME_PATH,android,$(DEPTH)/other-licenses/android)
> +SHARED_LIBRARY_LIBS += $(call EXPAND_LIBNAME_PATH,gonk,../gonk)
> +endif

Please share this with android.

::: mozglue/gonk/GonkGlue.cpp
@@ +31,5 @@
> + * and other provisions required by the GPL or the LGPL. If you do not delete
> + * the provisions above, a recipient may use your version of this file under
> + * the terms of any one of the MPL, the GPL or the LGPL.
> + *
> + * ***** END LICENSE BLOCK ***** */

Please use MPL2 header.

@@ +80,5 @@
> +      if (it->parent)
> +        it->parent();
> +  }
> +  return pid;
> +}

Please move that under mozglue/build, remove the mozglue/android/APKOpen.cpp corresponding code, and make both android and gonk build from mozglue/build.
(Reporter)

Updated

5 years ago
Assignee: nobody → mwu
No longer depends on: 738559
(Reporter)

Updated

5 years ago
Duplicate of this bug: 738724
(Reporter)

Updated

5 years ago
Blocks: 738559
(Reporter)

Updated

5 years ago
Depends on: 739003

Comment 3

5 years ago
Try run for 3fda485b5a53 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=3fda485b5a53
Results (out of 50 total builds):
    success: 42
    warnings: 8
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mwu@mozilla.com-3fda485b5a53
(Assignee)

Comment 4

5 years ago
Created attachment 612858 [details] [diff] [review]
Move common code to BionicGlue
Attachment #612858 - Flags: review?(mh+mozilla)
Comment on attachment 612858 [details] [diff] [review]
Move common code to BionicGlue

Review of attachment 612858 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozglue/build/BionicGlue.cpp
@@ +1,1 @@
> +/* -*- Mode: C++; tab-width: 40; indent-tabs-mode: nil; c-basic-offset: 2 -*- */

tab-width: 40!?
Attachment #612858 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4c40a352e2a4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
(Assignee)

Comment 7

5 years ago
wait why am I marking this as fixed
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/4c40a352e2a4
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.