Closed Bug 738600 Opened 8 years ago Closed 7 years ago

[Tracking] Plugin support in metrofx

Categories

(Core :: Plug-ins, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jimm, Unassigned)

References

Details

Conventional winapi plugins aren't compatible with the new metro environment. The largest issue is that secondary native UI (popout windows, fullscreen windows, option dialogs) all call win32 windowing apis, resulting in UI that shows up on the desktop instead being embedded in the metro interface. We need a solution to this for metro fennec.

Google has apparently solved this for at least two top tier adobe plugins (flash and acrobat) by using their Pepper APIs which rely on the host for UI creation. 

https://sites.google.com/a/chromium.org/dev/developers/design-documents/pepper-plugin-implementation

We've never adopted Pepper however. From what I understand we have a new competing standard. cc'ing some people who might know better what the status is on this work.

Overall we want some plugins running in metro. We may also try to run tab processes at a lower integrity which needs to be taken under consideration.

Filing this bug as a discussion / tracking bug for this work.
AIUI, IE will not be supporting plugins in Metro. Why do we feel that we need/want to? We already have a potential solution for PDF, and the mobile web is quickly making non-video Flash obsolete, and we have pretty good solutions for video Flash coming.
(In reply to Jim Mathies [:jimm] from comment #2)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> > AIUI, IE will not be supporting plugins in Metro. Why do we feel that we
> > need/want to? We already have a potential solution for PDF, and the mobile
> > web is quickly making non-video Flash obsolete, and we have pretty good
> > solutions for video Flash coming.
> 
> Asa has been thinking this over a lot - I'll let him chime in.

It's likely that other non-IE vendors are going to be shipping support for at least some plugins. We need to do this to be competitive.
Hi guys, I work on Chromium on the pepper team with brettw and darin. If you have any interest in considering implementing pepper, we'd happy to discuss how we can work together. As jimm noted, we're working towards running Flash and PDF within a sandbox by default using pepper. They already run this way in ChromeOS. The goal in the near term is to make plugins as secure as possible.

Feel free to drop me an e-mail any time. Another good way to reach us is the pepper-dev Google Group:
https://groups.google.com/a/chromium.org/group/pepper-dev/topics
I'm curious as to what the long-term solution for live streaming video on HTML5 is.

Until there's a standardized protocol, Flash will be necessary and perhaps the need to hack the PPAPI plugin to work with Firefox will be necessary.
You can stream at a constant bit rate just by sending a WebM file to <video>. We're also working on DASH support for WebM.
Component: General → Plug-ins
Product: Fennec → Core
Summary: Add support for (some?) plugins in metro fx → [Tracking] Plugin support in metrofx
Depends on: 767562, 781653
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 869603
Duplicate of this bug: 844358
Duplicate of this bug: 907549
For the record, we hoped to support plugins in Metro, but we haven't found a feasible way to do it.  We disabled plugins in bug 789600 because existing NPAPI plugins are not compatible with the Metro environment, and we have not been able to get plugin makers to provide versions of their plugins that do work with Firefox for Metro.  Bug 806536 has some of the technical details.

(For comparison: Chrome and IE both have limited support for plugins in Metro.  They support special versions of Flash, but no other plugins.)
Duplicate of this bug: 921838
Depends on: metro-shumway
Flash is definitely the big plugin to support in Metro. Even though there is HTML5 video, fact is there are too many sites that still rely on Flash.
(In reply to erosen03 from comment #12)
> Flash is definitely the big plugin to support in Metro. Even though there is
> HTML5 video, fact is there are too many sites that still rely on Flash.

At the moment, our best bet for supporting Flash content is Shumway (bug 967306).  For more information, see: http://mozilla.github.io/shumway/

After bug 967969 is fixed (within the next week, I hope), it will be possible to enable and begin testing Shumway in nightly development builds of Firefox for Metro, by toggling the "shumway.disable" preference in about:config.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.