Last Comment Bug 738647 - DOMStorageImpl::GetKey shouldn't throw
: DOMStorageImpl::GetKey shouldn't throw
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
: 509241 (view as bug list)
Depends on:
Blocks: 740357
  Show dependency treegraph
 
Reported: 2012-03-23 07:55 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-03-30 05:34 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (31.39 KB, patch)
2012-03-23 07:55 PDT, :Ms2ger (⌚ UTC+1/+2)
honzab.moz: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-03-23 07:55:10 PDT
Created attachment 608709 [details] [diff] [review]
Patch v1

http://www.whatwg.org/specs/web-apps/current-work/multipage/webstorage.html#dom-storage-key

| If /n/ is greater than or equal to the number of key/value pairs
| in the object, then this method must return null.

This fixes

http://w3c-test.org/webapps/WebStorage/tests/submissions/Infraware/storage_local_key_null.html
Comment 1 Honza Bambas (:mayhemer) 2012-03-26 17:30:46 PDT
Comment on attachment 608709 [details] [diff] [review]
Patch v1

Review of attachment 608709 [details] [diff] [review]:
-----------------------------------------------------------------

r=honzab

Thanks.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-03-28 10:41:05 PDT
*** Bug 509241 has been marked as a duplicate of this bug. ***
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-03-30 05:34:38 PDT
Thanks!

https://hg.mozilla.org/mozilla-central/rev/80aee211b0ce

Note You need to log in before you can comment on or make changes to this bug.