Switch application(Alt+Tab) is very slow when Google Presentation opened

RESOLVED INVALID

Status

()

Core
Graphics
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: Alice0775 White, Assigned: bas)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy:p2], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/ab2ff3b5611f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323031214

Switch application(Alt+Tab) is very slow when Google Presentation opened.
This happens on Windows only.

Reproducible: Always

Steps to reproduce:
1. Start Firefox and other application(such as Explorer)
2. Login Google

3. Open Google Docs Template Gallery https://docs.google.com/templates?type=presentations&pli=1#
4. Find "Beverage Package" and Click "Use This Template"
5. Wait completion of page loading

6. Switch to other application(Alt+Tab) or click Taskbar button
7. Switch back to Firefox(Alt+Tab) or click Taskbar button

Actual results:
  Switch application(Alt+Tab) is very slow 

Expected results:
  Should not slow
(Reporter)

Comment 1

6 years ago
In addition to the Steps to reproduce:

You may need to repeat Step 6 and Step 7 several times.
(Reporter)

Comment 2

6 years ago
Regression window
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/0c3bd5909e79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110420 Firefox/6.0a1 ID:20110420170520
Can reploduce:
http://hg.mozilla.org/mozilla-central/rev/46fdf12082d4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 ID:20110421030547
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0c3bd5909e79&tochange=46fdf12082d4

Triggered by:
fd8e217b2c84	Jonathan Kew — bug 642589 - expose prefs for tweaking DirectWrite/D2D antialiasing behavior. r=jdaggett
Blocks: 642589
Component: General → Graphics
Keywords: regression
QA Contact: general → thebes
(Reporter)

Comment 3

6 years ago
Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 0x1002
  Device ID: 0x954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.950.0.0
  Driver Date: 2-14-2012
  Direct2D Enabled: true
  DirectWrite Enabled: true (6.1.7601.17776)
  ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200
  WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
  GPU Accelerated Windows: 1/1 Direct3D 10
  AzureBackend: direct2d
(Reporter)

Comment 4

6 years ago
The problem does not happen if I disabled HWA.
See Also: → bug 738820
(Reporter)

Updated

6 years ago
(Reporter)

Comment 5

6 years ago
Created attachment 608906 [details]
semi reduced html
Whiteboard: [Snappy]
(Assignee)

Updated

6 years ago
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED

Updated

6 years ago
Whiteboard: [Snappy] → [Snappy:p2]
Alice, may you please check if this has improved at all in the latest Nightly?
Flags: needinfo?(alice0775)
(Reporter)

Comment 7

a year ago
The page will be unavailable in 2016.
So, I close this bug. no need track.
No longer blocks: 642589
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(alice0775)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.