Closed Bug 738820 Opened 8 years ago Closed 3 years ago

Page load is very slow on Google Presentation

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [Snappy:p3])

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/ab2ff3b5611f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120323 Firefox/14.0a1 ID:20120323031214

Page load is very slow on Google Presentation.

WonderCsabo reported similar problem
See http://forums.mozillazine.org/viewtopic.php?p=11850497#p11850497

Reproducible: Always

Steps to reproduce:
1. Start Firefox and other application(such as Explorer)
2. Login Google

3. Open Google Docs Template Gallery https://docs.google.com/templates?type=presentations&pli=1#
4. Find "Beverage Package" and Click "Use This Template"
5. Wait completion of page loading


Actual results:
  Page load is very slow on Google Presentation.
  It takes about 8 sec in Firefox5.
  It takes about 15 sec in Firefox and later.

Expected results:
  Should not slow

Regression window
Cannot reproduce:
http://hg.mozilla.org/mozilla-central/rev/0c3bd5909e79
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110420 Firefox/6.0a1 ID:20110420170520
Can reploduce:
http://hg.mozilla.org/mozilla-central/rev/46fdf12082d4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 ID:20110421030547
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0c3bd5909e79&tochange=46fdf12082d4

Triggered by:
fd8e217b2c84	Jonathan Kew — bug 642589 - expose prefs for tweaking DirectWrite/D2D antialiasing behavior. r=jdaggett


Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 0x1002
  Device ID: 0x954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.950.0.0
  Driver Date: 2-14-2012
  Direct2D Enabled: true
  DirectWrite Enabled: true (6.1.7601.17776)
  ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200
  WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
  GPU Accelerated Windows: 1/1 Direct3D 10
  AzureBackend: direct2d
The problem does not happen if I disabled HWA.
See Also: → 738806
I can confirm this bug. I could reproduce this on two computers, disabling HWA resolves the problem on both of them. I first ran into this when visiting this presentation page:
https://docs.google.com/presentation/d/1QgY4op4wbrqIUsuiw6I4MVikTcrhMQ-YJvDYccxUzlE/edit#slide=id.p13
but i can reproduce it with this one, too: https://docs.google.com/presentation/d/1JIUdN1eb1r2ZHK2Gb7DvqS-3mpV6QvM5GegZivVcmyY/edit#slide=id.g96f2286_0_27
Whiteboard: [Snappy]
Whiteboard: [Snappy] → [Snappy:p3]
The issue is no longer present in Nightly 16.0, cs: 6338a8988917.
I tested with both of presentations provided in my previous post. The loading takes about 8 seconds, but Chrome 21 uses this amount of time, too.

I'm on Windows 7 x64, everything is on default, HWA is on.
Fixed range(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/36e938e51481
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120522212625
Fixed:
http://hg.mozilla.org/mozilla-central/rev/aa2b52bd0374
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120523024422
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=36e938e51481&tochange=aa2b52bd0374


Fixed range(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/bbb12d0bcf49
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120521220651
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/abbf642df562
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120521222950
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bbb12d0bcf49&tochange=abbf642df562

I guess this is fixed by abbf642df562	Bas Schouten — Bug 715768: Enable Azure-Thebes wrapper by default for D2D. r=jrmuizel
Calling this fixed by bug 715768 based on comment 4.
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 715768
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.