Last Comment Bug 738858 - PDF Viewer homepage doesn't exist
: PDF Viewer homepage doesn't exist
Status: RESOLVED FIXED
[testday-20121101]
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Nobody; OK to take it and work on it
:
: Brendan Dahl [:bdahl]
Mentors:
http://support.mozilla.org/kb/Opening...
Depends on:
Blocks: 714712
  Show dependency treegraph
 
Reported: 2012-03-23 17:01 PDT by B.J. Herbison
Modified: 2012-11-01 15:18 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description B.J. Herbison 2012-03-23 17:01:40 PDT
Today's Nightly added PDF Viewer 0.2.414. The Add-ons Manager details for the item include a home page link of <http://support.mozilla.org/en-US/kb/using-mozilla-pdf-viewer>. That page does not exist.
Comment 1 Scoobidiver (away) 2012-03-24 06:16:49 PDT
I though it was https://support.mozilla.org/kb/Opening%20PDF%20files%20within%20Firefox which is a more generic article.
Comment 2 Verdi [:verdi] 2012-03-24 07:49:51 PDT
Bill Walker emailed me about this and I suggested that we update the article that Scoobidiver points out. Since we don't track support documentation in bugzilla we can probably close this.
Comment 3 Scoobidiver (away) 2012-03-24 08:07:18 PDT
(In reply to Verdi from comment #2)
> Since we don't track support documentation in bugzilla we can probably close this.
I disagree. The home page link must be set to the one in the URL field.
Comment 4 Thomas Ahlblom 2012-04-18 13:00:37 PDT
WFM:
Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120418 Firefox/14.0a1

https://support.mozilla.org/en-US/kb/Opening%20PDF%20files%20within%20Firefox

However, I don't know if we should resolve fixed PDF viewer bugs as WORKSFORME or FIXED.
Comment 5 Verdi [:verdi] 2012-04-18 13:18:58 PDT
Ok sorry - more info. I didn't realize that this was about linking to rather than the creation of an article.

http://support.mozilla.org/kb/Opening+PDF+files+within+Firefox is the correct target. If that url is going to be part of an html page that is separate from the bits shipped with Firefox (not sure how this part of the add-on manager works) then it should be written as above (no https, no locale). 

If the url is something that works like an in-product link (think question mark links in the preference panes), then we need to use a specially formatted url and we'll have to redirect that on sumo to the correct article. In this case (let me know if it is) we should use http://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/pdf-viewer
I don't think we'll have to set any of those variables since this will only show up when applicable and sumo will take care of showing a platform specific or locale specific (if it exists) version of the article.
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-04-18 13:32:53 PDT
http://hg.mozilla.org/mozilla-central/rev/7a89be8dbecc (bug 743264) fixed this link to point to https://support.mozilla.org/kb/Opening%20PDF%20files%20within%20Firefox .

It's hardcoded in the extension meta data, so we can't easily use the normal "in product link" mechanism. This solution seems fine for now.
Comment 7 Gabriela [:gaby2300] 2012-11-01 15:18:05 PDT
Verified fixed using Windows 7 and the latest Nightly.

Note You need to log in before you can comment on or make changes to this bug.