Last Comment Bug 738929 - Speed up building of layout/svg/base/src by cleaning up #include directives in its source files
: Speed up building of layout/svg/base/src by cleaning up #include directives i...
Status: RESOLVED FIXED
[include-what-you-use]
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Jonathan Watt [:jwatt]
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 738969 iwyu
  Show dependency treegraph
 
Reported: 2012-03-24 09:08 PDT by Jonathan Watt [:jwatt]
Modified: 2013-08-11 03:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (45.18 KB, patch)
2012-03-24 09:08 PDT, Jonathan Watt [:jwatt]
dholbert: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] 2012-03-24 09:08:41 PDT
Created attachment 609008 [details] [diff] [review]
patch

Following on from bug 721131, this patch cleans up the headers in the source files in layout/svg/base/src. The build time is only cut by 2% this time.
Comment 1 Daniel Holbert [:dholbert] 2012-03-24 20:09:41 PDT
Comment on attachment 609008 [details] [diff] [review]
patch

>+// Keep in (case insensitive) order:

Extreme nit, which I'm only mentioning because this comment may end up appearing across a significant fraction of the codebase if these bugs take off, and it'd be nice to be consistent:

I believe "case-insensitive" (with a hyphen) is more commonly-accepted (/ correct?) than "case insensitive" (no hyphen). For what it's worth, https://en.wikipedia.org/wiki/Case_sensitivity has it hyphenated, and there's a section on the "Talk" page discussing this very question: https://en.wikipedia.org/wiki/Talk:Case_sensitivity#hyphen-sensitive

It doesn't really matter, but if you agree & feel like doing a search-and-replace across the patch, I wouldn't complain. :)
Comment 2 Jonathan Watt [:jwatt] 2012-03-26 05:01:24 PDT
Sure thing, I made that change and pushed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/78e3ec2adbdf
Comment 3 Matt Brubeck (:mbrubeck) 2012-03-26 11:31:01 PDT
https://hg.mozilla.org/mozilla-central/rev/78e3ec2adbdf

Note You need to log in before you can comment on or make changes to this bug.