Last Comment Bug 739708 - layout/reftests/canvas have 16 tests that fail on android
: layout/reftests/canvas have 16 tests that fail on android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Jet Villegas (:jet)
:
Mentors:
: 739711 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 11:23 PDT by Joel Maher ( :jmaher)
Modified: 2012-07-16 11:48 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joel Maher ( :jmaher) 2012-03-27 11:23:01 PDT
On android xul, we run with e10s and our reftest harness will setup the xul window to have the remote=true attribute.  For native fennec we have the preference to turn on e10s set, but we don't read it.  This means that reftest is still thinking we are remote, but in reality we are not.  

In trying to turn this off, I found that we have 16 tests which pass on android-xul, but are failing now on native with the browser.tabs.remote pref turned off.

The log file showing this is here:
http://people.mozilla.org/~jmaher/android_reftests/canvas.log
Comment 1 Joel Maher ( :jmaher) 2012-03-30 10:35:56 PDT
Can we get somebody to look at this bug?  This might knock out half of our failing reftests by figuring out why these canvas tests are failing.
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-03-30 20:49:18 PDT
(In reply to Joel Maher (:jmaher) from comment #1)
> Can we get somebody to look at this bug?  This might knock out half of our
> failing reftests by figuring out why these canvas tests are failing.

Jet?
Comment 3 Daniel Holbert [:dholbert] 2012-04-04 17:58:02 PDT
I'm not eager to jump into this (I don't have a mobile build config right now), but for the record, the failing tests from comment 0 are:
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/size-1.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/image-shadow.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/size-change-1.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-ltr-left.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-ltr-right.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-rtl-left.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-rtl-right.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-ltr-left.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-rtl-left.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-big-stroke.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-big-stroke.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/text-bidi-ltr-test.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/linear-gradient-1a.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/linear-gradient-1b.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/evenodd-fill-1.html 
http://mxr.mozilla.org/mozilla-central/source/layout/reftests/canvas/693610-1.html 

See also the tests listed in bug 739711 comment 1. (which appear to be failing for the same reason)
Comment 4 Daniel Holbert [:dholbert] 2012-04-05 13:24:02 PDT
*** Bug 739711 has been marked as a duplicate of this bug. ***
Comment 5 Joel Maher ( :jmaher) 2012-04-12 09:18:39 PDT
can we get somebody to look at this?
Comment 6 Joel Maher ( :jmaher) 2012-05-30 12:07:55 PDT
I am going to mark the manifest file as failing on android&&browserIsRemote.  This is the XUL case only.  As this passes on Android Native and we are focused on Native development I vote for closing this bug as wont fix.
Comment 7 Jet Villegas (:jet) 2012-05-30 12:12:27 PDT
Please add the relevant check-in for the manifest file, then close this one. Thanks!
Comment 8 Joel Maher ( :jmaher) 2012-05-30 12:36:29 PDT
ok, I mixed these up with another test, these tests are in parity for failing both on android xul and native!
Comment 9 Joel Maher ( :jmaher) 2012-05-30 12:51:19 PDT
ok, reopening this as per discussion in irc with :dholbert.  We should figure out why these tests fail in general on Android which is different from the original intention of the bug to figure out why we are getting different results between xul and native.
Comment 10 Daniel Holbert [:dholbert] 2012-07-16 11:23:23 PDT
jmaher, is this still an issue?  This bug is still open, and yet it doesn't look like these tests have been flagged as failing. Are they still causing trouble anywhere?
Comment 11 Joel Maher ( :jmaher) 2012-07-16 11:48:22 PDT
these are running on both xul and native android fennec builds and appear to be passing.  this snuck through the cracks.

Note You need to log in before you can comment on or make changes to this bug.