Unable to purchase an app on Android/Native browser

RESOLVED WONTFIX

Status

Marketplace
Consumer Pages
P4
normal
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: krupa, Assigned: spasovski)

Tracking

ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-kilimanjaro:?)

Details

(Whiteboard: [woomp])

(Reporter)

Description

6 years ago
Android/ Native browser

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US/search
2. Click on the purchase buttons for one of the paid apps
3. Click "yup"

expected behavior:
PayPal flow begins

observed behavior:
Nothing happens
Blocks: 741557
Priority: -- → P1
Assignee: nobody → cvan
Target Milestone: --- → 6.5.0
This is super important but ain't a priority for beta. Will address after beta.
Target Milestone: 6.5.0 → 6.5.3
Not a blocker for beta.
Priority: P1 → P3
Target Milestone: 6.5.3 → 6.5.5
Blocks: 752013
No longer blocks: 735054
Priority: P3 → P2
Assignee: cvan → nobody
Component: Public Pages → Consumer Pages
Product: addons.mozilla.org → Marketplace
QA Contact: web-ui → consumer-pages
Version: unspecified → 1.0
Cvan: do you know anything about this bug? Front/back?  Is this us or platform?
(In reply to Wil Clouser [:clouserw] from comment #3)
> Cvan: do you know anything about this bug? Front/back?  Is this us or
> platform?

I know nothing unfortunately - Davor, wanna investigate?
(Assignee)

Comment 5

6 years ago
"To the bee-mobile!", "You mean your Chevy?", "Yes."

I got it.
Assignee: nobody → dspasovski
(Assignee)

Comment 6

6 years ago
Here's the summary of what I found.

This issue happens when trying to make a one-time payment from the payment modal, after you click the details page purchase button. Nightly will prompt the user for whether to show a popup (this is the PayPal popup - on Desktop it would be an iframe). When the browser asks the user to allow the popup, it will not actually open it even if you select "always show" or "show once". If you pick "always show" and later revisit the page and reinitiate the purchase flow it will work.

I managed to complete a purchase on mobile both locally and on marketplace. The real issue here is to figure out why we're getting an "allow popup" dialogue and furthermore why it doesn't open the popup even if you select "allow".

The user experience of doing this is obviously unpleasant but it could be much better if the popup opens as expected and without an allow prompt. We might want to chat about this as a team and/or with the fennec folks.
Blocks: 749446
No longer blocks: 752013
Blocks: 756282
No longer blocks: 749446
(Assignee)

Comment 7

6 years ago
Potch since you're looking at mobile bugs this one is a biggie...although I think it has since been fixed with the removal of the labs-hosted JS shim.
Assignee: dspasovski → thepotch
Target Milestone: 2012-05-17 → 2012-05-24

Updated

6 years ago
OS: All → Android
Hardware: All → ARM
Assignee: thepotch → dspasovski
Target Milestone: 2012-05-24 → 2012-05-31
Whiteboard: [woomp]
Target Milestone: 2012-05-31 → 2012-06-07
Is this still the case?

Updated

5 years ago
blocking-kilimanjaro: --- → ?
If this is still happening in Firefox for Android, we need it fixed for Aug 28. It's currently still in a milestone from 2 months ago.
Davor is back tomorrow.  Davor - what did you find out about this?
Priority: P2 → P1
Target Milestone: 2012-06-07 → 2012-08-09
(Assignee)

Updated

5 years ago
Target Milestone: 2012-08-09 → 2012-08-16
Priority: P1 → P4
Target Milestone: 2012-08-16 → ---

Comment 11

5 years ago
Give that mobile is the main focus for apps now, why is this low in priority?
(In reply to JP Rosevear [:jpr] from comment #11)
> Give that mobile is the main focus for apps now, why is this low in priority?

Near term milestones don't include payments on the android platform.
The why: free apps are first priority. current target for payments is oct-nov. dependencies include FxOS & Identity.
PayPal payments are disabled.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.