Password field empty for accounts created using browserID

VERIFIED FIXED in 2012-08-23

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P3
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: jrconlin)

Tracking

unspecified
2012-08-23

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Admin tools-> Users
2. Pick an account created via browserID (https://addons-dev.allizom.org/en-US/admin/models/auth/user/6115955/)
3. Notice that Password field is empty
4. Add some privileges and hit save.



observed behavior:
Unable to make changes to the account since password field is empty.
what is the use case here? what privileges are you trying to add?
(Reporter)

Comment 2

6 years ago
(In reply to Kumar McMillan [:kumar] from comment #1)
> what is the use case here? what privileges are you trying to add?

You cannot make any changes to an account created using browserID which includes making them an editor/admin or granting them access to view stuff on our site. This will be a problem when we make browserID the only way to register in AMO/MP.
does the reset password link from the admin pages work?
Assignee: nobody → ashort
Priority: -- → P4
Target Milestone: --- → 6.4.9
Target Milestone: 6.4.9 → 6.5.0
Target Milestone: 6.5.0 → 4.x (triaged)
FYI - I'm blocked by this issue to access marketplace.mozilla.org, as I appear to have hit this corner case. Is there a work-around?
(Reporter)

Comment 5

6 years ago
We should fix this problem asap as new editors are hitting this
 usecase on prod.
Severity: normal → major
Priority: P4 → P2
(In reply to krupa raj 82[:krupa] from comment #5)
> We should fix this problem asap as new editors are hitting this
>  usecase on prod.

What do you mean new editors are hitting this? What's happening?
(Reporter)

Comment 7

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #6)
> (In reply to krupa raj 82[:krupa] from comment #5)
> > We should fix this problem asap as new editors are hitting this
> >  usecase on prod.
> 
> What do you mean new editors are hitting this? What's happening?

STR:
1. User creates a new account using browserID/persona
2. We gant them editor privileges so that they can review apps for us
3. User tries to log in to marketplace.


observed behavior:
They never clear the second authentication step since we don't store their password.
https://github.com/mozilla/zamboni/commit/ce1b45d
Assignee: ashort → cvan
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 4.x (triaged) → 6.5.3
If you someone has an account created with browserID and I try to give that person admin/reviewer access he/she will not be able to log in since we require a non-browserID password to authenticate. Grr...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://github.com/mozilla/zamboni/commit/7829435

You can reset/create your password using

https://addons.mozilla.org/en-US/firefox/users/pwreset
https://marketplace-dev.allizom.org/en-US/users/pwreset
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Reopening since I reverted: https://github.com/mozilla/zamboni/commit/691f9b1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 6.5.3 → 6.5.4
Blocks: 752013
No longer blocks: 735054
Severity: major → normal
Priority: P2 → P3
I ported https://addons.mozilla.org/en-US/firefox/users/pwreset to https://marketplace-dev.allizom.org/en-US/users/pwreset but it broke some things. Until I can more closely look at that, I'm bumping this.

If you forget your password, use https://addons.mozilla.org/en-US/firefox/users/pwreset for now.
Target Milestone: 2012-05-10 → 2012-05-24
Target Milestone: 2012-05-24 → 2012-05-31
This really isn't a big deal right now. Maybe I'll revisit it later.
Assignee: cvan → nobody
Target Milestone: 2012-05-31 → ---
No longer blocks: 752013
(Assignee)

Updated

6 years ago
Assignee: nobody → jrconlin

Comment 14

6 years ago
Migration took 79.13 seconds on -dev fwiw.
https://github.com/mozilla/zamboni/commit/3b86471

Thanks, JR! Yeah that's a hefty migration.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2012-08-23
(Reporter)

Updated

6 years ago
Depends on: 785521
(Reporter)

Comment 16

6 years ago
The form cant be edited due to a traceback. But that's bug 785521

We got rid of the password field. Marking this verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.